Can't Import 3d model.



  • So I made this 3d model on SetchUp and exported it in .obj format, but Clip Studio Won't let me drag and drop it. I also tried with FBX and couldn't do it, either. I only get a "denied" symbol on my cursor.

    Any ideas?
    Thanks!



  • Are you trying to drag the object onto an open canvas?



  • @garlam Yes, I am.
    Actually, just realized I can't drag images, either.



  • Are you on a Mac or PC?



  • @garlam On PC! I use Windows 10.



  • I can't figure out what's happening with your drag and drop. If you're dragging the obj or the image file directly onto an open canvas then it should drop.



  • A couple of possibilities on both images and models...

    There is a good chance your model is there but you aren't seeing it. First and foremost, in the tool properties, click on the light source check box. If that doesn't reveal anything, look to see if Clip Studio created a 3D layer. If so, select that layer and then look somewhere near the bottom half of the canvas for a button that looks like a gray square with a plus "+" sign in the middle of it. Click on that, which should center your model into the picture frame no matter what it's location. If that doesn't work, in the Tool Properties on the left side tried adjusting the object scale slider and see if that brings it into view. 3D is a weird animal that I've dealt with a lot, and when moving models from one program to another, you often don't get what you would expect, so you have to figure things out.

    One last possibility. This is a problem I've seen with SO MANY SKETCHUP MODELS... It's possible that your model is inside out, or in other words, the faces of your polygons that should be facing inside your model are facing outside your model. If this is the case, your model will be invisible in any program other than Sketchup. The way you can tell is when you are in Sketchup, open up your model and go to the drop down menus: VIEW>TOOLBARS and then click the STYLES box. A set of cubes will show up as tool buttons. Click the last one which should look like a two color cube. Now your model will appear either white or blue (or a combination). White is good, blue is bad. Click on your model, on a single face, anywhere where it is white and make sure that face stays selected by keeping your mouse hovered over that face, right mouse click and choose orient faces. Now your whole model should appear white. That is what you want if it wasn't white before. Now it won't be invisible in other programs. If you have any other questions on this just post and I'll be happy to answer them.



  • @xiombarg Hey! Thanks for the reply! I'm pretty sure it's a different problem. Here's a gif showcasing it.



  • It's a little hard to make out but it looks like your 3D object is 3DS. That's not a supported file. Supported 3D files are lwo, lws, fbx, obj, 6kt, 6kh, c2fc, and c2fr. Not that I think that's the problem because it looks like the image file is a jpeg and that should drop. But you should try to drag and drop a supported 3D file to see if it works (if you haven't already).



  • Huh, that is weird. Almost like it's rejecting the format. It could be that it's rejecting something in the export information that comes with your .obj model. You could try just exporting a simple a cube in Sketchup and see if you can drag and drop that into Clip Studio, because if you can do that, then there is something weird about your model itself that Clip Studio doesn't like. There is a free plugin called Clean Up for Sketchup that helps get rid of problems in your model. You could try using it before exporting.

    But I keep forgetting that you said you have an image that won't drop in either... It might be that your Clip Studio just needs to be re-installed?



  • Would it be possible to send me the 3D file? OBJ please. I'll check on my end both for errors in the object and if I'm capable of importing it so we'll know if it's a fault of the app or something with your install.

    talexander@smithmicro.com



  • @garlam You're right, it was 3ds, however changing to .obj didn't solve the problem. As you suggested, I also tried other 3d models from forums that were working for everyone else, but no luck.
    @xiombarg I've been testing and it's not just an image that won't drop in, absolutely nothing will. I'll try reinstalling once I back everything up.
    @Teyon Ok, I'll send it to you. It's a pretty simple model. However, I'm pretty sure it's a problem with the application since I can't drag and drop absolutely anything into an opened canvas.

    I'm going to try reinstalling.
    Is there a way to backup my custom brushes and screentones so I don't lose them?



  • Back Up your Celsys_EN folder found in My Documents. Keep a copy of it someplace else. The folders within contain the information for your setup like brushes and materials. When you reinstall, move the new Celsys_EN folder to a new location (for safety's sake) and replace it with the copy of your current Celsys_EN folder.



  • Reinstalling fixed the issue!
    No clue what was going on, but I'm glad it's all sorted out now.

    Thanks everyone for your help!



  • Sorry was out of the office most of the day. Glad you got it sorted out though.