Cycles based plugin(s) for EZskin3.

  • @bopperthijs

    Thank you so much!

    It is freely available on my dropbox, if that's ok for you.
    Here is the link

    If you don't agree, I'll remove it.

  • That's ok for me! Thank you. I have a dropbox myself, but I completely forgot about that. I use it too little, I guess.

  • @bopperthijs

    Cool :-)
    I've a lot of place on it, so that's not a problem.

  • Ok, Have fun with it.

  • PDF states that there is an updated version of EZSkin3 inside the zip. I cannot find this file. Do I need to go back to CGBytes and down load a new version from them?

  • @ghostship
    Sorry that's a leftover from the former version.
    As long as you have the latest version of EZskin3 , it will work.

  • @bopperthijs Thanks dude! I'll check out the goods after dinner!

  • OK, now I feel stupid. I don't do python scripting so I have no idea where these other two files go for EZSkin3 to use them. The two files are and The PDF states to put them in the EZSkin3 directory...I don't have a separate directory for EZSkin3, it's in the scripts menue folder. Additionaly, should the sun-tan maps have their own folder and in the textures folder if these scripts are going to call to them?

  • When you installed EZskin3, which I presume you did, you have made a map called EZskin3, probably in your documents-map. In that map called: EZskin3 you have a map called "Custom shaders". When you put the plug-ins in that map, EZskin can find them. The map suntanmasks don't need to be in a texture map, but somewhere, where you can find them. preferly also in the EZskin map. You have to set the suntanmask every time you apply the shader, because sadly enough, EZskin forgets where they are.

    I hope this will help you.

  • My EZSKIN3 is located in: Poser 11/Runtime/Python/poserScripts. it is by itself and shows up in the poserScripts menue. There are no other folders that I know of. When you say "map" do you mean to say "folder?"

  • a screen shot would be handy

  • Yes, sorry I meant folder. I thought that was a dutch word, so I didn't used it.
    This is where my files are stored:


    It's called EZskin3-preview because I had a beta version of EZskin3, but I suppose it's now called EZskin3.

    I hope this made it more clear. In the EZskin (not mine ) documentation is described how to install EZskin3 and where to put your files.

    I hope this made it more clear.

    Sorry it's in dutch : in means in english : c: > users > M.Broekhuijsen > Documents > ezskin3- preview

  • After some reading of the manual I found what I needed to do. Plug-in installed. Yes, I am ignorant! Thanks for the help.

  • I am having an issue while using "EZSkin CycleMaterials" with Hameleon's Primavera dress:

    Traceback (most recent call last):
    File "E:\POSER\EZSkin 3\", line 5531, in Apply
    File "F:\Poser\3D Lib\Render Tools\EZSkin\ezskin3\Custom shaders\", line 94, in BuildShader
    method(mat, p)
    File "F:\Poser\3D Lib\Render Tools\EZSkin\ezskin3\Custom shaders\", line 317, in CycleCloth
    nc07=mat.AddNode('weave', name = 'ProceduralCloth', loc = (700,700), collapsed=False, preview=False, inputs = weavedict)
    File "E:\POSER\EZSkin 3\", line 3868, in AddNode
    ValueError: too many values to unpack

    I have tried using one of the default poses, and without any node connected to the root one.
    What can I do?

    Note that from time to time, the issue happens with "EZ_CycleSkin" too. In that case, I apply the character's default skin (non-sss version) and most of the time it runs smnoothly without problems.

  • @Y-Phil
    I think it's a bug, I'll try to fix it.
    Thank you for reporting.

    When you apply a firefly material to a figure, just keep it as simple as possible, if possible no SSS.
    Just a color map , transparant map (if neccessary, lashes ) and bump or normal map.
    If you have a complicated shader, then EZskin will have difficulties to find the appropiate maps.
    The plug-in will apply a procedural bump when it can't find a bump or normal map, but a colormap is a must.

  • @bopperthijs

    Before reporting it to you, I have even tried with no nodes attached at all but it still continues to encounter the same difficulty.
    Tell me if I can help you.

  • The bug is in the procedural bump I think, I have to try it later. because poser is busy with rendering.

  • @bopperthijs

    No worries, I'll wait. I have to explore a compound "Dieletric Node" ;-)

  • @Y-Phil
    I've tried to reproduce your error ( I happened to have the same dress), but it worked okay for me.
    Do you have the latest version of EZskin3? The older one will give the kind of error you mentioned.
    But I did actually find some other problems with this dress, I have make some improvements.

  • @bopperthijs

    Before trying anything, I have re-downloaded the version from my account on cgbytes, and it sills indicate "Build 083"
    I have a ZIP file containing the build 88 that still shows "Build 083" in the About window and it does the same thing.
    Is there somewhere a more recent version?