Strange bug in latest poser update on mac

  • I just applied the update to poser pro 11. I am on a macbook pro 15 in 2014 running OSX Yosemite.

    Ever since I did the update I can no longer use control c and control v to copy and paste in the material room. I also cannot use the mouse to drag and select the entire shader structure. It will only select one shader node at a time.

    This has really slowed me down in the material room.

    I have reset my poser preferences. I have also manually trashed my preferences. I have reset my pram and smc on my Macbook therefore it seems like it is a bug in the latest release of poser.

    I have sent an e-mail to poser support about this.

    has anyone else with a mac experienced this strange behavior in the material room?

  • Upon further investigation it only happens on the files I have already created and saved as pz3 files with poser prior to the update. Not new files I make after this new update.

  • Sadly, I can't help. For the first time in the recorded history of man, I've had to abandon using Poser 11 on my current Mac and use a windows PC. I've never used Poser on anything else. My first Poser was Poser 2. I still have the disk, box and manual. Excuse me.... i think I'm going to cry.. :(~~~

  • @eclark1849 said in Strange bug in latest poser update on mac:

    Sadly, I can't help. For the first time in the recorded history of man, I've had to abandon using Poser 11 on my current Mac and use a windows PC. I've never used Poser on anything else. My first Poser was Poser 2. I still have the disk, box and manual. Excuse me.... i think I'm going to cry.. :(~~~

    I was a Mac user for years (since 1986) and switched to PC about 5 years ago. My pocketbook thanks me.

  • @ghostship Interestingly enough, I've only owned two brand new Macs in my life and like you, I've been using them since about 1985-6. Money was never a problem, until now.

  • @david_macrae I've had the same issues you describe, along with a couple of other weird bugs, with this update. I'm also on a Mac, but I'm running El Capitan.

    Just two of the weird things that have started happening since this last update...

    When I click Image Source on a node in the Material Room, each resultant window keeps appearing further and further to the right. I have a feeling this is related to the new support for interface scaling on large screens. I have a 5k Retina monitor and having tried to enable Retina support in the past, I had similar weird results with item placement.

    There are also issues with the Area Render tool. I was told this was "an artifact of the video card", which is utter nonsense, because it didn't happen before this last update, and as I pointed out to the Customer Service guy, I can only render via CPU. (It would be nice if he knew what he was talking about before dismissing my experience...) I had enjoyed being able to "patch" renders where necessary (e.g. render a scene and touch up small imperfections with the Area Render tool, right on that previous render), but this new update leaves empty lines on the render, or only completes the area render and turns the rest of the image black. This has borked my workflow and has really slowed me down because I have to re-render if something isn't quite right.

    And this one frustrated me, but then made me laugh after my heart attack had subsided... Renders appear to quit before they're done, leaving empty space where the image is incomplete. But I discovered that if you run the Compare Renders slider back and forth, voila, the render has actually finished. Funny joke, guys. Not.

    Weird. Just weird.

  • @James_in_3D uncheck "render in separate process" that should fix the problem you are having with doing spot renders.

  • @ghostship I wish that was the solution. Been doing that for years. Have it set that way currently. No joy. Thanks, though. :)

  • @david_macrae
    Didn't get that far - all sorts of things went strange after I updated - mouse in particular played up. So your best plan is to revert to the previous update (32600), which should be stored on your Mac*.
    Watch out for the activation issue - if you exceed 3 activations Poser will stop working and you'll have to go back to SMicro to get that problem sorted out.
    I deactivated Poser, removed it; reinstalled it from DVD and then applied the previous update (32600).
    I now have Poser Pro 11 running nicely again on Yosemite and won't be applying any further SR until someone assures me it's been fixed for Macs.

    • user/(you)/SmithMicroDownloadManager/Downloads/update/installed/Install Poser 11 Update (

  • @eclark1849
    See above reply to david - it should help you too. I've always used Macs.

  • Thanks everybody.

    @A_Sunbeam I dont have the last patch as I always delete them from the download manager after updating. I did have that problem with activations in the past when I tried upgrading to El Capitan. I had to revert back to Yosemite because another program I use for effects "Particle Illusion" does not work with El Cap. Still waiting on an answer from support.

    I believe you can now manage activations yourself at the pgportal:!/

    although I have not actually tried to since.

  • @david_macrae
    I can send it to ypu if you want it.

  • @A_Sunbeam that would be great my email is
    Did you have to reinstall poser or just run the patch again?

  • @david_macrae
    See email.

  • @A_Sunbeam I will probably not get to it until tonight since I have to reinstall I will let you know how it goes.

    I hope they stabilize the update for mac as there were some engancements I was looking forward to.

  • Upgrading and reinstalling Poser can consume an activation slot. (You normally have 3) if that happen you absolutely can control activation on the PG Portal.

    Look for "Licenses" in the top navigation. Click the license you need to reset. Click the "edit" button at the bottom. Now check the "Show Advanced Options" check box.


    Really read it. Please?

    Ok, now you can see all the active computers on that license. Click "more info" too see the friendly name of the computer. That will hopefully help you recognize the ones the you need to remove.

    You only get to do this once ever three months so choose wisely.

    Now, back to the issue at hand:

    Please submit this issue to support. If copy n' paste is broken in the material room we'll ge on fixing it. It helps us to have exact system specs and the sample scenes to reproduce it. Support can collect that info and pass it on the the engineers.

  • I've checked on a couple of Macs and the click-and-drag-drag-to-select-nodes thing seems to be a Retina issue with where the selection rectangle selects things (which in this case is different from where it displays the rectangle as you drag, thus the bug). Shift-clicking nodes works, although it's a bit clunky. Can't replicate the failure to copy & paste- maybe a different palette, like the library, has focus?

  • For now, to work around the click-and-drag select issue, I right-click, choose "Select All", right-click again, choose "Copy" (or delete or whatever).

    @nerd3d Chuck, I'm recording a few video screen caps of what I'm experiencing. I've sent the video links to support. Hopefully that will be a little more helpful for them rather than sending them static screenshots!

  • @nerd3d
    Signed in at Portal, clicked on licences - no licence numbers appeared, just the option to "add new licence".

  • @nerd3d ...But apparently support can't access YouTube. Seriously?

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.