Strange bug in latest poser update on mac

  • @david_macrae
    Didn't get that far - all sorts of things went strange after I updated - mouse in particular played up. So your best plan is to revert to the previous update (32600), which should be stored on your Mac*.
    Watch out for the activation issue - if you exceed 3 activations Poser will stop working and you'll have to go back to SMicro to get that problem sorted out.
    I deactivated Poser, removed it; reinstalled it from DVD and then applied the previous update (32600).
    I now have Poser Pro 11 running nicely again on Yosemite and won't be applying any further SR until someone assures me it's been fixed for Macs.

    • user/(you)/SmithMicroDownloadManager/Downloads/update/installed/Install Poser 11 Update (

  • @eclark1849
    See above reply to david - it should help you too. I've always used Macs.

  • Thanks everybody.

    @A_Sunbeam I dont have the last patch as I always delete them from the download manager after updating. I did have that problem with activations in the past when I tried upgrading to El Capitan. I had to revert back to Yosemite because another program I use for effects "Particle Illusion" does not work with El Cap. Still waiting on an answer from support.

    I believe you can now manage activations yourself at the pgportal:!/

    although I have not actually tried to since.

  • @david_macrae
    I can send it to ypu if you want it.

  • @A_Sunbeam that would be great my email is
    Did you have to reinstall poser or just run the patch again?

  • @david_macrae
    See email.

  • @A_Sunbeam I will probably not get to it until tonight since I have to reinstall I will let you know how it goes.

    I hope they stabilize the update for mac as there were some engancements I was looking forward to.

  • Upgrading and reinstalling Poser can consume an activation slot. (You normally have 3) if that happen you absolutely can control activation on the PG Portal.

    Look for "Licenses" in the top navigation. Click the license you need to reset. Click the "edit" button at the bottom. Now check the "Show Advanced Options" check box.


    Really read it. Please?

    Ok, now you can see all the active computers on that license. Click "more info" too see the friendly name of the computer. That will hopefully help you recognize the ones the you need to remove.

    You only get to do this once ever three months so choose wisely.

    Now, back to the issue at hand:

    Please submit this issue to support. If copy n' paste is broken in the material room we'll ge on fixing it. It helps us to have exact system specs and the sample scenes to reproduce it. Support can collect that info and pass it on the the engineers.

  • I've checked on a couple of Macs and the click-and-drag-drag-to-select-nodes thing seems to be a Retina issue with where the selection rectangle selects things (which in this case is different from where it displays the rectangle as you drag, thus the bug). Shift-clicking nodes works, although it's a bit clunky. Can't replicate the failure to copy & paste- maybe a different palette, like the library, has focus?

  • @nerd3d
    Signed in at Portal, clicked on licences - no licence numbers appeared, just the option to "add new licence".

  • @James_in_3D I was shift selecting on each node which was annoying then I tried what you suggested to right click and nothing happened. Then I realized the mouse has to be on a node then you can right click and select all and it works.

    I now have the old update but have not applied it yet because I still have a ticket open with support and am waiting to see what happens. Or if they need further info I will be able to provide.

  • @nerd3d said in Strange bug in latest poser update on mac:

    Upgrading and reinstalling Poser can consume an activation slot. (You normally have 3) if that happen you absolutely can control activation on the PG Portal.

    Thank you for clearing that up for me. I keep 'running out' of activations even though I only have Poser on two computers. I actually contact SM about this the other day, because the computer I almost always use needs a repair, so I went to check on Poser in on my desktop and was told my trial period had expired. Support was nice enough to reset my activations for me, but they seemed to insist the issue was that I kept activating it on multiple computers and that I was turning off the option for sending analytics (which I don't, I figure I want SM to know the sort of hardware I like to run Poser on).