Rendering Problem



  • Have you tried using the Preview renderer to do this at all?



  • @Teyon Hi, if you're referring to the Camera icon in Preview mode, I tried that too, and the results are the same. It still render out to Texture Shading.

    0_1472443714452_Rendering-Problem9.jpg



  • @redphantom I started messing around with the "Alternate_Diffuse" color palette that connects to the Toon node in the Advance section of the Material Rooms. I use the eyedropper tool to select the skin tone color of the figure. I then render it from the Render Settings, and this was the render:

    0_1472445618170_Rendering-Problem11.jpg

    Before I rendered it, this was my settings in the Material Room:

    By default, the "Alternate_Diffuse" color palette was automatically set to White. I'm not sure why it was set to white. I thought the software would do a better job at detecting the right color that needs to be ink outlined.

    0_1472445868562_Rendering-Problem12.jpg

    I then mess with the color and randomly select the skin flesh tone (a light brown color).

    0_1472446107074_Rendering-Problem13.jpg

    and the render turned out like this:

    0_1472445618170_Rendering-Problem11.jpg

    I don't know if this is progress but at least it's showing something different.



  • When I set the "Alternate_Diffuse" color to Black, the skin color of the figure renders out to Black:

    0_1472446716549_Rendering-Problem14.jpg

    0_1472446824158_Rendering-Problem15.jpg

    Anyone has any clue on why Poser is not detecting the outline, or if I'm not setting the diffuse color properly?



  • @Twister1996 no. I'm saying go to the render menu, click render settings. Hit the tab that says preview and then hit render. You may want to hide the ground plane first though.



  • @Teyon I just did as you say, but the result is still the same.

    This is in preview mode:

    0_1472458367654_Rendering-Problem16.jpg

    This is my Render Settings.

    0_1472458466254_Rendering-Problem17.jpg

    I then select the Preview tab

    0_1472458582122_Rendering-Problem18.jpg

    This is the render result:

    0_1472458695418_Rendering-Problem19.jpg



  • @Teyon I even tried it with the other fella's suggestion; setting up Toon Render in the Material Room. It still outputs to Texture Shading Render.

    0_1472458936645_Rendering-Problem20.jpg



  • @Teyon The only way I can get a cartoon render is by setting the Preview room to Comic Book mode and then render through menu: Render > Anti Alias Document

    and the other method you mentioned: Render > Render Settings > Preview Tab > Render Now

    0_1472461063438_Rendering-Problem21.jpg

    0_1472461076039_Rendering-Problem22.jpg

    but I don't think either method is the same as Rendering through Render > Firefly Settings. I would be missing out on all the Firefly settings, including the Pencil, Pen, or Marker option in the Toon outline section.



  • You may want to make the Alternate Diffuse color chip white instead of black. I feel like maybe that's the problem.
    See my Andy.
    0_1472477616541_alternate diffuse.PNG

    If you used the Set Up Toon Render script, I don't think it's smart enough to ask you what color you want to use, so it leaves it black. Change it to white and then in the Toon node, change the various colors to whatever you feel you want to see. Keep in mind the Ink Color is an outline color so leaving that Black would be wise.

    If that still doesn't work out for you, contact Tech Support.



  • @Teyon mmm, I tried setting Alternate_Diffuse to White and it still didn't produce the cartoon rendering.

    I will send this problem to Tech Support, but they haven't been responsive with another problem that I was encountering. I actually get more answers from here then through tech support.



  • for a production render (That's Firefly or SUperfly) you will have to set up the materials for all the objects and all the materials in that scene. The setup toon render wacro will only get you so far.

    One thing it does that may be wrong is it keeps the image maps attached. Usually you don't want image maps attached. for toon style tenders. It doesn't look cell shaded.

    Also the Document display style has nothing to do with a production render. It only affects the PREVIEW render. Some people find the preview render give the results they want without waiting for a production render.

    Whatr you probably need to do is make a simple skin color shader like shown. (Note the falloff and line values. Then apply it to his whole body. Then give the car the same treatment. discard all the existing shaders and replace it with a simple toon setup.

    0_1472491296299_ToonSEtup.jpg