Poser executable stopped working



  • "Poser Pro executable file has stopped working"
    this is the message I'm getting since yesterday when I try to open myscene1.pz3 or myscene2.pz3

    workflow as follows:
    all started by getting a crash while working on myscene2.pz3 (can't remember doing anything particular / different from what I had already done when getting this first crash),
    then upon trying to reload the scene, kept getting the same message reported above (Poser loads the interface, then everything fades to pale white, and a popup window informs me with the generic notice "a problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available")

    The odd thing is that if I now try to load the backup file myscene1.pz3, I get the same message and everything freezes as well, even if I was able to open that just fine before this dreadful crash!
    Basic "andy2" scene, and previous simpler scenes I made, still load just fine.

    I've searched around and found a suggestion to delete preferences, tried (both single preference files and whole folder) but no luck, still everything freezes.
    Even uninstalled internet explorer (that was suggested too for some users being betrayed by an update..) but that didn't help either.
    I'm on Windows7 Professional SP1
    Poser version 11.0.5.32974

    I'm a bit distressed because I've been working some days on that scene, and even cautiously made a backup file, but this didn't help :(
    Any suggestion would be warmly welcomed, thank you.

    P.S. is there any bug-report repository I would better submit this issue to?
    Is there any log file I can access to backtrack/ help backtracking the issue?



  • Just a stab in the dark here, but do you have "Use external binary morph targets checked" under the Misc tab of your General Preferences? If so, try unchecking it and see if the files load.



  • Ok, now I'm really in trouble.
    Being clueless on a possible solution, I tried reinstalling Poser, mistakenly thinking that this would have not touched my (corrupted and uncorrupted) scenes, being safely stored elsewhere: .pz3 and .pmd files.
    After reinstalling and loading those scenes, Poser prompts me for figurename.pmd and propname.pmd
    files I can't locate in my hard drive.
    Was it additional info on the characters and props of those scenes, stored in Poser's own program folder?
    Would guess so, as my character is now completely untextured, hairless and naked, after days spent conforming clothing from other figures...
    And know what? Even when ingnoring these missing files, Poser still crashes with the two scenes I had issues with!

    I guess my noobishness is to blame now, for making a bad issue still worse.
    But this short experience has been traumatic.. after a couple weeks of delight with the software, those issues destroyed my work. I'll consider wether to continue using this -otherwise very capable- software again, not sure I'll dare to spend another three weeks to get same scenes up and running, only to risk them being not accessible again :(



  • @modus0
    thank you for the input!
    That option was indeed checked, tried unchecking and loading, but still get the crash :(



  • @erwin_sc

    I confirm that by the past, I've lost a few scenes because of that option being checked. Now, I live with it off.
    But there's a function that I have activated: the auto-save option. It has saved my life many times...

    That being said: it may be silly but... have you looked in Windows' trashbin?



  • @Y-Phil
    no I didn't :D took a look now, and unfortunately there's nothing valuable there

    I did uninstall before reinstalling Poser, I guess any modification it keeps asking when I load pz3 files has been lost in the void :((

    The odd thing is that I did backup saves, but all of them suddenly become not accessible after that cursed crash, even if they worked just fine up to some hour / day before.

    (btw: what do you guys backup additionally to my_file.pz3 and my_file.pmd?)



  • @erwin_sc

    MAy I ask another silly question? Are you storing your projects files in one of Poser's Runtime "scene" folder?



  • No, I'm saving them on a desktop folder: "my_projects/project_name/scenes/"
    to allow for quick access / searching.. hope that's a fine location :)

    I have some positive news though, maybe worth reading for anyone experiencing similar issues, I'll try to summarize but there are some different things to notice, so I'll try to mention all of them as well.

    Things as follows:
    I had another backup file of an early save of that same "corrupted" scenes, and that backup file opened fine. I dismissed that at first because it was "too early" stage, but at least I had some of my characters in there*.
    That old backup was saved with "Cartoon" display style.
    After loading that, and changing to "Texture shaded", the system freezed again.

    Here's the most interesting news: I tried removing a pretty complex object from the scene (a tree with foliage) which was already causing a noticeable slowdown while working - and now changing to "Texture shaded" didn't cause the freeze!
    (Notice that I was able to switch to texture shaded previously, before the first awful crash, even with the complex tree inside)

    So, I think those two savefiles that I can access no more were saved in "Texture shaded" format, and for some odd reason my computer is no more able to handle those scenes in texture shaded mode with the complex tree inside. Thus every loading results in a crash.
    (is there a way to load a scene starting in a different document style?)

    Now I have another BIG issue though (aside from rebuilding my scenes and making without that nice tree I bought..): I can't access the "face" room!!
    It simply doesn't launch, clicking the "Face" tab simply does nothing, a one second mouse cursor load and then revert back to whatever room I was in.

    Now, should I reinstall everything again and cross my fingers like a custom morph? :|

    (* note: after reinstalling poser last night I lost all textures references in my old backup scene and had to manually readd them, plus some .pmd or .obz files were missing... I spent hours trying to fix everything, and failed. Then, luckily I had a backup of my "general preferences/settings", and after recovering those settings, all these textures/objects issues were magically fixed, and now I have some of my textured characters back in full shape and color! Don't know exactly how, but.. hooray!)



  • @erwin_sc

    The story of that tree causing problems reminds me of a bag for women that I was using. As long as I didn't changed any of its morphs, firefly could render it without problems.
    I've never found which morph I changed but I know that the way I posed it (i.e. with some morphs setting changed) it didn't froze poser but firefly was systematically crashing...
    Speaking of slowdown: I have experimented this with some hair props causing the render time to explode, probably because I used a too high number for the transparency settings at render time.
    Last point: I can't access the "Face" room, too, whatever the character: Alyson2, Pauliine Dev or Vic4



  • Thanks for the feedback, I'm glad (well, kind of :D) hearing that similar issues may happen,
    at least there's some common ground and shared knowledge on the matter.. though I'll be very careful from now on with objects I add to scenes, and make sure I'll backup scenes prior to adding new relevant objects.

    @Y-Phil said in Poser executable stopped working:

    Last point: I can't access the "Face" room, too, whatever the character: Alyson2, Pauliine Dev or Vic4

    Oh, really? I thought this was very strange, but again it's very interesting knowing that this may happen. So there is no known solution for this?
    If I may ask, how do you manage to create your customized faces (if external softwares - don't you miss the builtin simplicity of face room?)



  • @erwin_sc
    Well.. ur... in fact: I've never used the Face room: there's so much to do and learn with poser, and I've not enough free time to do everything I would like, so that actually I rely on a mix of different packages



  • Ah, thank you,
    I may end up doing the same then, if this issue doesn't solve!
    (though I liked the face room quite much :D)

    Another thing I'm going to try next days is probably installing Poser on another computer,
    see if I experience same issues on the scenes,
    and hopefully make my custom faces from there...
    (and then, hopefully, buy a better computer and hope everything will get better!)



  • @erwin_sc

    I was a fan of Win7. Conform to Micro$oft's tradition: one on two OSes is perfect, while the other one should be... avoided
    But... Micro$oft's tradition, too: each 3-5 years, the OS must be re-installed from scratch or replaced with a new one, because of increasing instabilities...
    That was my case. Even with an SSD drive, Win7 needed 2.5 minutes to load.
    And in my case, I had to replace the motherboard+cpu+ram because it wasn't compatible with Win10.

    That leads me to wonder if one of Poser's problems with your computer couldn't be... win7 itself or one of its numerous DLLs...



  • @Y-Phil
    Yeah, that's definitely something I can't rule out,
    my Win7 dates about a year and a half, it's not dramatically unperformant - still
    (loading times are very quick, but I've been cautious on what to install in this machine)
    Reinstalling the OS is something that I should probably consider... I usually wait for things to get unbearably slow before doing that :D but in this situation this could be effectively something to try...
    wish Poser had some sort of log at least telling me why the crash did happen!
    (assuming there's not such a log - if anyone knows, I'll happily learn)



  • @erwin_sc
    Poser has its own log, useful when looking for errors in the mat room: menu Windows -> Log
    But I doubt that this log will help you determine what made poser crash. I mean: it can be a geometry that reacts wrongly when its morphs are changed...
    May I ask which tree you were speaking of? to see if I have the same or not.



  • @Y-Phil
    Yeah, thanks, I've seen that log, but as you say, unfortunately I can't access that when loading those scenes (as i get insta-crash)

    This is the tree I was using:
    http://www.turbosquid.com/FullPreview/Index.cfm/ID/401535
    (imported from 3DS model)
    It worked fine for a couple days, then the awful crash,
    now in an old backup (crashing if I set it to "texture shaded" display mode)
    removing this tree caused the scene to work again finely.

    To avoid misunderstanding: I'm sure the model is fine, not saying this tree causes crashes, I'm just guessing my computer can't handle its complexity!



  • @erwin_sc

    Beautiful tree... it works perfectly on my system.
    Note that most of the time, I work in texture shaded mode.

    The only place you will find a log in case of crash is in windows' events viewer.



  • @Y-Phil
    Thanks, I didn't think of that, will take a look, but maybe I'll only find windows error codes there?

    Yeah, that's a beautiful tree I'll miss :°°°(

    Btw, gathering infos on the "Face room" issue, found this post, may be worth an investigation :D
    http://forum.runtimedna.com/showthread.php?79329-Face-Room-Tab-does-nothing



  • @erwin_sc

    I remember having clicked on the Face tab with Vic4 loaded. The reaction was something like "incompatible figure", which was quite normal. But the tab was displayed.
    In our case, it doesn't even open.



  • @erwin_sc, what kind of cpu do you have, and how much ram?

    I ask because looking at that turbosquid page, that tree has 1.2 million polygons. If you're already experiencing slowdown with the tree in the scene, it could quite possibly be the culprit for Poser being unable to load the scene file.

    In contrast, Pauline Casual has @ 93,551 polygons (figure and hair), and V4 has @ 67, 550 just the figure.

    Couldn't say about the Face room issue, I've never bothered with it since it only works with the Poser native figures, and I almost never use them.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.