Poser executable stopped working

  • Thanks for the feedback, I'm glad (well, kind of :D) hearing that similar issues may happen,
    at least there's some common ground and shared knowledge on the matter.. though I'll be very careful from now on with objects I add to scenes, and make sure I'll backup scenes prior to adding new relevant objects.

    @Y-Phil said in Poser executable stopped working:

    Last point: I can't access the "Face" room, too, whatever the character: Alyson2, Pauliine Dev or Vic4

    Oh, really? I thought this was very strange, but again it's very interesting knowing that this may happen. So there is no known solution for this?
    If I may ask, how do you manage to create your customized faces (if external softwares - don't you miss the builtin simplicity of face room?)

  • @erwin_sc
    Well.. ur... in fact: I've never used the Face room: there's so much to do and learn with poser, and I've not enough free time to do everything I would like, so that actually I rely on a mix of different packages

  • Ah, thank you,
    I may end up doing the same then, if this issue doesn't solve!
    (though I liked the face room quite much :D)

    Another thing I'm going to try next days is probably installing Poser on another computer,
    see if I experience same issues on the scenes,
    and hopefully make my custom faces from there...
    (and then, hopefully, buy a better computer and hope everything will get better!)

  • @erwin_sc

    I was a fan of Win7. Conform to Micro$oft's tradition: one on two OSes is perfect, while the other one should be... avoided
    But... Micro$oft's tradition, too: each 3-5 years, the OS must be re-installed from scratch or replaced with a new one, because of increasing instabilities...
    That was my case. Even with an SSD drive, Win7 needed 2.5 minutes to load.
    And in my case, I had to replace the motherboard+cpu+ram because it wasn't compatible with Win10.

    That leads me to wonder if one of Poser's problems with your computer couldn't be... win7 itself or one of its numerous DLLs...

  • @Y-Phil
    Yeah, that's definitely something I can't rule out,
    my Win7 dates about a year and a half, it's not dramatically unperformant - still
    (loading times are very quick, but I've been cautious on what to install in this machine)
    Reinstalling the OS is something that I should probably consider... I usually wait for things to get unbearably slow before doing that :D but in this situation this could be effectively something to try...
    wish Poser had some sort of log at least telling me why the crash did happen!
    (assuming there's not such a log - if anyone knows, I'll happily learn)

  • @erwin_sc
    Poser has its own log, useful when looking for errors in the mat room: menu Windows -> Log
    But I doubt that this log will help you determine what made poser crash. I mean: it can be a geometry that reacts wrongly when its morphs are changed...
    May I ask which tree you were speaking of? to see if I have the same or not.

  • @Y-Phil
    Yeah, thanks, I've seen that log, but as you say, unfortunately I can't access that when loading those scenes (as i get insta-crash)

    This is the tree I was using:
    (imported from 3DS model)
    It worked fine for a couple days, then the awful crash,
    now in an old backup (crashing if I set it to "texture shaded" display mode)
    removing this tree caused the scene to work again finely.

    To avoid misunderstanding: I'm sure the model is fine, not saying this tree causes crashes, I'm just guessing my computer can't handle its complexity!

  • @erwin_sc

    Beautiful tree... it works perfectly on my system.
    Note that most of the time, I work in texture shaded mode.

    The only place you will find a log in case of crash is in windows' events viewer.

  • @Y-Phil
    Thanks, I didn't think of that, will take a look, but maybe I'll only find windows error codes there?

    Yeah, that's a beautiful tree I'll miss :°°°(

    Btw, gathering infos on the "Face room" issue, found this post, may be worth an investigation :D

  • @erwin_sc

    I remember having clicked on the Face tab with Vic4 loaded. The reaction was something like "incompatible figure", which was quite normal. But the tab was displayed.
    In our case, it doesn't even open.

  • @erwin_sc, what kind of cpu do you have, and how much ram?

    I ask because looking at that turbosquid page, that tree has 1.2 million polygons. If you're already experiencing slowdown with the tree in the scene, it could quite possibly be the culprit for Poser being unable to load the scene file.

    In contrast, Pauline Casual has @ 93,551 polygons (figure and hair), and V4 has @ 67, 550 just the figure.

    Couldn't say about the Face room issue, I've never bothered with it since it only works with the Poser native figures, and I almost never use them.

  • Hey, welcome to the club: sometimes Poser breaks for no apparent reason, and doesn't give any hint of what's wrong.

    That's just a fact of life with this program. It has been this way forever. The only way to counter that (besides pulling your hair when the darn thing crashes) is to version your scenes, like filename1.pz3, filename2.pz3, filname3.pz3, etc..., and pray that some problem created in say filename1 gets copied all the way to filename3, and then when you find it in filename3 you'll see you also lost filename1 and filename2.

    Some things that I try when the stupid thing starts to crash on me are these:

    (a) Open a fully new scene, use File / Import from your old file; sometimes this clears whatever junk the old file has

    (b) Turn down to minimum everything that causes memory utilization (texture size, shadows, preview quality) then try to open your file; this never really fixed anything for me, but I try anyway

    (c) If you manage to open the file but it crashes on save or some operation, go to Hierarchy Editor, select anything that looks odd and you can live without, select it and delete it; many times this works, as there are things that are visible in Hierarchy Editor but are not visible in regular selection process

    (d) If you can't delete something in Hierarchy Editor chances are that may be the source of corruption; create a new object (like a ball), use Hierarchy Editor to change the parent of the trouble to that ball, then delete the ball; many times this saved my skin

    (e) Clear all your simulation; a few times this fixed it; then delete all simulations; a few other times this also fixed it.

    By the way, I just SOOOO wish that there was a "Sanity Check" function that would check the internals of a file and just delete what's wrong (like bad pointers, bad whatever else). Or that there was some exception handling that would say "Duh, program crashed when accessing texture", so that you'll know what area is corrupted. Instead we're left completely in the dark, with zero information and no idea how to recover when the darn thing just explodes on our hand.

  • @modus0
    Thank you for your suggestions, here are my specs:
    Intel(R) Core(TM) i5-4250U CPU @ 1.30GHz
    4 GB RAM
    to update the history, I had another savefile-corrupting crash yesterday, and I already removed that tree from the scene, so I guess he was not the (only, if being at all) culprit :(
    luckily, this time I had some other 6 savefiles of the scene, and the previous one still working, so I can go on rebuilding my scene (almost done... phew!)
    Interesting analysis though, I'll surely take a closer look at polycount next time I'll go shopping :D

    Thank you! I'm glad having posted my issues here, there is a lot of helpful and nice people around :)
    Reading on your experience is a relief (again, the kind of relief of being on same boat with others), and your suggestion on scene versions is pure gold, this is what I started doing since yesterday, and already saved me from another day of pain!
    Whish I did this from the beginning. I'll need another HD though :DD

    (a) OMG!!! It worked!! Took something like 5 minutes to load the scene but it was able to open one of my dreadful "corrupted" scenes!!!! This is GREAT - thank you!! Now I know I didn't need to rebuild all things I did today and yesteday... but I'm happy anyway!!!

    I'll keep in mind all of your other suggestions, and hope I won't need to "import" broken scenes again, but at least now I know there's also this last chance!

    Wish SM will take a look at our wishes and implement sanity checks or error-log features in the future, would be quite useful for bug reporting also!

    (Face room still not working, after some experimenting.. whish I didn't reinstall, it worked just fine before :(

  • @erwin_sc

    I would like to suggest something: when I have a rather complex scene to build, I create independent scenes. Once each renders correctly, I save one version without the lights.
    Finally, I create a new empty scene and I import each independent part, sometimes in many steps (each step = 1 version of the main file)

  • @Y-Phil
    Thank you, I'll try doing this to plug the tree again in the scene then, might be a safer way (crossing fingers)
    I didn't even notice the "import scene" feature of Poser - glad it exists :D

  • @erwin_sc Glad it worked!