Poser executable stopped working

  • Hey, welcome to the club: sometimes Poser breaks for no apparent reason, and doesn't give any hint of what's wrong.

    That's just a fact of life with this program. It has been this way forever. The only way to counter that (besides pulling your hair when the darn thing crashes) is to version your scenes, like filename1.pz3, filename2.pz3, filname3.pz3, etc..., and pray that some problem created in say filename1 gets copied all the way to filename3, and then when you find it in filename3 you'll see you also lost filename1 and filename2.

    Some things that I try when the stupid thing starts to crash on me are these:

    (a) Open a fully new scene, use File / Import from your old file; sometimes this clears whatever junk the old file has

    (b) Turn down to minimum everything that causes memory utilization (texture size, shadows, preview quality) then try to open your file; this never really fixed anything for me, but I try anyway

    (c) If you manage to open the file but it crashes on save or some operation, go to Hierarchy Editor, select anything that looks odd and you can live without, select it and delete it; many times this works, as there are things that are visible in Hierarchy Editor but are not visible in regular selection process

    (d) If you can't delete something in Hierarchy Editor chances are that may be the source of corruption; create a new object (like a ball), use Hierarchy Editor to change the parent of the trouble to that ball, then delete the ball; many times this saved my skin

    (e) Clear all your simulation; a few times this fixed it; then delete all simulations; a few other times this also fixed it.

    By the way, I just SOOOO wish that there was a "Sanity Check" function that would check the internals of a file and just delete what's wrong (like bad pointers, bad whatever else). Or that there was some exception handling that would say "Duh, program crashed when accessing texture", so that you'll know what area is corrupted. Instead we're left completely in the dark, with zero information and no idea how to recover when the darn thing just explodes on our hand.

  • @modus0
    Thank you for your suggestions, here are my specs:
    Intel(R) Core(TM) i5-4250U CPU @ 1.30GHz
    4 GB RAM
    to update the history, I had another savefile-corrupting crash yesterday, and I already removed that tree from the scene, so I guess he was not the (only, if being at all) culprit :(
    luckily, this time I had some other 6 savefiles of the scene, and the previous one still working, so I can go on rebuilding my scene (almost done... phew!)
    Interesting analysis though, I'll surely take a closer look at polycount next time I'll go shopping :D

    Thank you! I'm glad having posted my issues here, there is a lot of helpful and nice people around :)
    Reading on your experience is a relief (again, the kind of relief of being on same boat with others), and your suggestion on scene versions is pure gold, this is what I started doing since yesterday, and already saved me from another day of pain!
    Whish I did this from the beginning. I'll need another HD though :DD

    (a) OMG!!! It worked!! Took something like 5 minutes to load the scene but it was able to open one of my dreadful "corrupted" scenes!!!! This is GREAT - thank you!! Now I know I didn't need to rebuild all things I did today and yesteday... but I'm happy anyway!!!

    I'll keep in mind all of your other suggestions, and hope I won't need to "import" broken scenes again, but at least now I know there's also this last chance!

    Wish SM will take a look at our wishes and implement sanity checks or error-log features in the future, would be quite useful for bug reporting also!

    (Face room still not working, after some experimenting.. whish I didn't reinstall, it worked just fine before :(

  • @erwin_sc

    I would like to suggest something: when I have a rather complex scene to build, I create independent scenes. Once each renders correctly, I save one version without the lights.
    Finally, I create a new empty scene and I import each independent part, sometimes in many steps (each step = 1 version of the main file)

  • @Y-Phil
    Thank you, I'll try doing this to plug the tree again in the scene then, might be a safer way (crossing fingers)
    I didn't even notice the "import scene" feature of Poser - glad it exists :D

  • @erwin_sc Glad it worked!