GoZ doesn't work or crashes PoserPro 11 sr5

  • Poser Pro 11 sr5 freshly installed.

    Load up a figure, I'm experimenting with one of the cartoon characters: Ginger 2.

    Select either the body or a body part.

    In object|Export object to GoZ, choose "body part" and click okay. The figure becomes invisible and nothing else happens. Choose display and select any mode and the figure becomes visible again.

    Repeat the same, only go to Figure and choose GoZ. Choose the settings and click OK. Poser just quits -- without a dialog or crash log notice. No Zbrush, nothing.

    Mac os X 10.11.6, 16Gb Ram. iMac with Nvidia video card w/4Gb vRAM.

    GoZ worked on SR 3 & 4 iirc.

    zBrush has the correct path to PP11 sr5.

    Reinstalled SR5, problem persists.

    GoZ works in that "other" Posing app ;>

    Any ideas what I can do? zBrush sez that Smith Micro programs the GoZ and they have no control over it. And there's nothing I could (albeit with one search) find that yields any clue as to what I can set up/configure on Poser's side.


  • In Poser the figure turns invisible but then ZBrush opens and the body part loads and you do what you have to do in ZBrush, hit the GoZ option in the Subtool menu, which should bring you back to Poser, where you then give the morph a name and VOILA...your figure is no longer invisible.

    Is that not happening for you? If you're exporting to GoZ, why are you messing with Poser at that point? Shouldn't you be in Zbrush until you're done?

  • Wasn't clear enough -- zBrush never opens. If I have both Zbrush and Poser open, nothing happens when I try to export a body part. zBrush has the "default" objects in the sub tool menu.When I try to export a body part, The body vanishes and Zbrush gets nada, even after waiting 5 minutes or so. When I export a figure ZB or Poser crashes.

    Discovered that Zbrush 4R7 has a "favored" goZ app, changed it to Poser. Same issue. This time Zbrush crashes and there's a crash log.
    IN short, I'm still messing with Poser because Zbrush never opens or gets anything from Poser. IOW: The first step in using zBrush for morphs never happens.
    I have no idea what to do next.

  • Poser Ambassadors

    Try deleting the contents of Users/Public/Pixologic/GoZApps/Poser (Make a back up first). You now may have to relink Poser first from ZBrush/
    It might be that a corrupt GoZ file is stored in that folder which is messing things up

  • @wimvdb on my Mac, the only thing in Users is a folder for Dropbox. In shared, there's a Pixologic folder, but it contains the "guts" that allow GoZ for Poser to work, getting rid of it just makes Poser vanish from the GoZ list. But the basics of GoZ works, as I can export from zBrush to Poser, but cannot get anything from Poser to zBrush. And I don't know where the folder that contains goZ files is on my mac.

    Well, what started out as just some messing around has consumed a few hours of my day. I'm close to just saying that goZ worked on Poser at one time. Now it doesn't and leave it at that.

    But if anyone has Mac specific help, I'd appreciate it.

  • Poser Ambassadors

    @cartoonMike - The GoZ files @wimvdb is referring to are the ones in Users/Shared/Pixologic/GoZApps/Poser on a Mac. It is possible one of these could be corrupted, so for a full troubleshoot, backup then delete these files then reinstall Poser. Start Zbrush (4r7 has beta 64-bit and stable 32-bit versions, shouldn't make a difference but would be safest to use 32-bit version); open Preferences/GoZ & either update all paths or check if path to Poser is correct; set it manually if in any doubt.

    If it still doesn't work, get in touch with SM support - if GoZ with SR5 on Mac is broken, it's a pretty good bet that other users will have reported the issue. GoZ is working OK for me on Win10 with SR5, but unfortunately I don't run any 3d apps on my Mac as it's too old.

  • @caisson Thanks. I followed your instructions and still no joy. So with this being a long weekend, Guess I'll contact SM Support and see what's happening.