Tool problems after update



  • Hello,

    Recently i've been having a lot of problems using Clip Studio Paint, the issues began after I updated to the latest wacom driver, I normally try to avoid updating as this seems to happen every time I do.

    Essentially it changes tool modes for no reason, for example I will be in pen or brush mode and it will switch to move mode. So whilst I’m in the middle of creating a line it will suddenly change layers and move that layer. or it will switch to zoom mode. If i create folders for layers it will open up the layer and select it for me.

    Also if i need to switch to hand mode to quickly move to another part of the drawing without zooming out, it doesn’t register when i press the hot key, unless i completely move the pen away from the tablet and wait for the symbol to appear and even then is temper-mental, this has made the program unusable.

    I know its not a computer problem as I get no issues in any other programs I use, to be honest it was working perfectly until I got the latest wacom driver update. and updated to my safari security.
    My Computer is aMacBook Pro (Retina, 15-inch, Mid 2015),2.5 GHz Intel Core i7, 16 gb memory

    and i have the latest CSP 1.5.4

    Thank you very much, I would really appreciate your help.

    Jayce CL



  • What Wacom device are you using and what driver? I've had lot's of problems with my Cintiq 27 Touch if I ever open an on-screen or radial menu. Basically, when you close it, it leaves a phantom invisible menu behind, and you can trigger the command that were there, causing weird phantom events. If I restart and never use the onscreen menus it works fine. This has been a long time Wacom problem that they don't seem able to fix. It's been confirmed with other users.

    I was aslo having general stroke problems with newest Wacom driver, but they had me downgrade to a previous version and that issue went away.. The driver I'm using now is 6.3.15-3.



  • Ah forgot to mention that, my bad. Its a cintiq13HD and Like I mentioned in the OP I have the latest driver (6.3.17-5).

    I had lag issues with it before I got the latest CSP update but once i updated and its been perfect, up until now.

    I don't use any wacom hot key buttons as, like you i found out none of them work, I don't really mind that because i just use the keyboard for shortcuts.

    I've also tried several previous drivers, to see if it would fix the problem unfortunately without success.

    Thanks for the speedy reply.



  • You could try reinitializing your tools (or the whole program) by holding down shift when you launch and selecting the items you want to reset. I was having strange problems once and did this (making a copy of my settings folder first (documents/CELSYS_EN). Strange behavior resolved, and then I copied back settings in batches until the problem started again. In my case it was a corrupted tool file from a brush I imported. If you don't have a lot of custom tools or shortcuts, you can just reinitialize and not worry about adding things back in.



  • Wow it worked! , I reinitialised everything and its running smooth as butter now. Thank you so much! Now that you mention it I did import a brush around the same time I updated so, That most likely was the culprit, again thanks a lot, you have been a massive help :)


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.