"fireflies" in render ... more details


  • Poser Ambassadors

    Fireflies

    So here are my renders based on the findings in the thread "Post your Superfly Renders".

    1. Standard Clamp Direct and Idirect Samples in the render settings.

    0_1475850741889_Clamp10_2.png

    1. Clamp Direct .1, Indirect 10.

    0_1475850807274_Clamp10_1.png

    1. Clamp Direct .1, Indirect .1

    0_1475850848959_ClampPoint1_2.png

    There is definitely a loss of quality in the .1 on both clamps that doesn't make it worth the fireflies. So ... I'm asking how else to help with this issue? (Hopefully without making as setting that renders into the new year).


  • Poser Ambassadors

    Working on one with the Branch Tracing off and 30 samples. Seeing what that comes up with.



  • @Boni Let me know what you find Boni. I will try to find time this weekend to run some more tests/examples using various settings. Also, would you mind including a shot of your render settings along with each test shot? :)


  • Poser Ambassadors

    These settings are simple really. default except for the minor changes noted. But I will gladly include a screenie of the setting I'm working on now. By the way ... it's turning out great! (so far)



  • @Boni Yay! :D


  • Poser Ambassadors

    Ok, here we go:

    0_1475866092108_30_NoPath.png

    And the settings

    0_1475866145732_2016-10-07.png

    Please excuse the black background. I use high contrast for my vision.



  • @Boni That looks pretty good to me!


  • Poser Ambassadors

    The real test will be with bb's envirosphere. I have a test scene I'm working on.



  • So I took some time this morning to run some more tests, and I'm not really sure just what the results mean. I think I have a selection of settings that will produce an acceptable image for the scene that I'm working on, but I am not sure of the ramifications of all of my findings. Anyway, here is what I've found.

    I started with a base image that had fireflies in it:

    0_1475950032928_Pool Setup 010.jpg

    With these render settings:

    0_1475950050514_settings 10.JPG



  • Next I increased Max Bounces on the right, but that did not make a difference. The next setting that did make a difference was Diffuse Samples:

    0_1475950184542_Pool Setup 011.jpg

    Render Settings:

    0_1475950200944_settings 11.JPG



  • That was still clearly not the solution though. I adjusted all other settings under Branched Path Tracing: Glossy, Transmission, Subsurface, Volume, AO, and Mesh Light Samples. They were all turned up to 20, but made no difference to the results.

    So I started adjusting all of the settings along the right side. They also made no difference to the resulting render. I left them turned up in the render settings though so that you could see that I had adjusted them all.

    Then I turned down Clamp direct samples and Clamp indirect samples:

    0_1475950457529_Pool Setup 012.jpg

    Render settings:

    0_1475950469742_settings 12.JPG



  • Better, but still not an acceptable result. Next I turned off Branch Path Tracing and increased the Pixel Samples. This seems to fix the firefly issues, but it does not properly render the lights as you can see in the render:

    0_1475950602213_Pool Setup 013.jpg

    Render Settings:

    0_1475950612408_settings 13.JPG



  • Next I tried Progressive Rendering, but with the same render settings. It basically turned out the same as the image above, including the incorrectly rendered lights, but then the render settings were identical so I guess that is not surprising.

    It seems very odd to me that turning off Branch Path Tracing messes up the lights and their reflections. My understanding of what that setting does would imply that there should be no difference between a render using Branch Path Tracing and a render without it - other than the time it might take to render said image. This seems like a bug to me that the lights would render very differently with Branch Path Tracing turned off.

    I turned Branch Path Tracing back on, left the Pixel Samples at an increased level, and adjusted both Clamp settings as suggested. This produces an acceptable final image. So I know how to get an image I'm happy with, and I know that it is a combination of Pixel Samples, Branch Path Tracing, and Clamp settings to achieve that effect.

    0_1475951110166_Pool Setup 015.jpg

    Render Settings:

    0_1475951120917_settings 15.JPG



  • Further testing revealed the reason that the lights are rendered incorrectly with Branched Path Tracing turned off. That reason is that it greys out (or turns off) the following two settings:

    Sample all lights direct
    Sample all lights indirect

    This still seems like a bug to me, because should we not have the option to sample all lights even with Branched Path Tracing turned off?



  • @mr_phoenyxx What color are your walls and ceiling? The darker they are the less light they will bounce around.


  • Poser Ambassadors

    I will show my results later on Monday I only have access to my work machine in short spurts on the weekend. I think we are getting ahead on this.



  • @ghostship Whatever color you would call that in the render? Some kind of grey? :)



  • with branch path tracing checked your diffuse samples, glossy samples etc. are multiplied by the Pixel Samples number. With branch path tracing unchecked all rays have the same number of samples indicated by the Pixel Samples number. If you set all your individual samples to 3 and set Pixel Samples to 10 it is the same as turning off branch path tracing and setting your Pixel Samples to 30.



  • @ghostship Except that it does not give the same render results, as clearly indicated by these tests - at least in this particular scene. Your description was my understanding of how the setting works, however turning Branched Path Tracing off also turns off both Sample All Lights settings which clearly gives different rendering results



  • @mr_phoenyxx Turning off branch path tracing turns ON Sample All Lights. Turning on branch path lets you choose how many samples of each ray it does and gives you the choice of weather you want to sample ALL lights in the scene.

    Page 556 of the manual: "Unchecking the Sample All Lights Direct and Sample All Lights Indirect settings will produce faster renders, but will probably be noisier."

    So with branch path tracing turned off you need to crank up the main samples to get a better render. 15 samples is way too low to get a decent render especially in such a dark scene as you've got there . I've been setting it to 40 or 50. I'd set it higher but I'm not running a fast machine and don't have GPU rendering.


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.