Strange issue with Clip Studio Paint on OS Sierra

  • I'm having a strange issue with Clip Studio Paint on OS Sierra. Basically, sometimes when I press the pen down on my Intuos Pro Medium size, (latest driver) It's as though I clicked the desktop or the window behind the Clip Studio Paint window. I can click right in the middle of the canvas and it will go to the desktop or the window behind if there is one.

    I opened sketchbook pro to do an experiment to make sure it was not just the tablet. I had the sketchbook window in front of the clip studio window. I repeatedly clicked the canvas on sketchbook with the pen. All I did was create a bunch of dots. I then moved the Clip studio window in front of the sketchbook window and did it again. This time, I clicked on the sketchbook window that was behind the clip studio window. I also repeated the experiment with my laptops track pad and nothing happened so it only happens with Clip studio paint and the tablet.

    This didn't start happening until after I installed OS Sierra and the latest driver. It doesn't happen every time. I can be drawing for a couple minutes and suddenly I press down and it goes to desktop. Has anyone else had an issue like this or does anyone know why this might happen? I hope I explained it in a way that makes sense.

  • @SpiritualBacon The same exact thing is happening to me! Unfortunately, I haven't found a way around it either... :( Let's hope whatever it is, it's addressed soon; it's not a game-breaker, but it sure is annoying.

  • @eizumii Today I uninstalled and reinstalled Clip Studio Paint and the problem seems to be resolved so that's what I recommend you do

  • @SpiritualBacon I'll do just that then, thank you!

  • @SpiritualBacon Same issue for me, but when I first got clip studio paint the product key didn't work so I had to use it two times, and I believe you can only use it twice, so if I uninstall clip studio paint will I have to enter the license key?

  • @AurumGold It doesn't mean that after two times the key doesn't work anymore and you have to get a new one it means you can only use that key on two machines. So if you have it on two machines, uninstall one, you can use that key on a new machine. For me, I uninstalled it (I've installed it on two machines already) and reinstalled it and it was already activated when I reinstalled it. So I think if you don't deactivate it before uninstalling it you might not need to reenter the key when you reinstall it.

  • Had the same issue. I restarted CSP with the shift key down and that worked.

  • Same here, but restart with shift didn't do the trick.

  • @SpiritualBacon I have been hearing from many MacOS developers that its a bad idea to upgrade to OS Sierra any time soon because of all the back end breaking of applications.

    I haven't had any problems with Silkypix DS Pro 7 but then they don't rely much on native Mac stuff.

  • @SpiritualBacon Funny, just yesterday I found out that I can't run the update to Reality for Poser 4.3 until the next point update to Mac OS 10.12 (Sierra) because it "broke" something that the installer needs.

  • @rofu I solved it now with reinstalling Clip Paint Studio instead the old Manga Studio. Works now.

  • Hello I just update to Sierra and i'm having the same issue.
    It's embarrasing to me to draw with CSP files or images embed in my canvas with every stroke i make.

  • I just got a new mac with OS Sierra and had this issue occur. However, i 'bought' the most recent update for my Manga Studio 5 to Clip Studio pain 1.6.2. Free update/download on the website. Everything is working just fine now!

  • I know this is an old thread but I finally solved the problem today by upgrading from Sierra to High Sierra. If anyone else is still having the same problem, that upgrade might fix it!

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.