PP2014 - Meshlineartefacts on glass



  • Simple 12-sided cylinder in PP2014 rendered (1) as is, (2) with one level of subd, (3) with smoothing.

    0_1476461350841_renders.jpg

    Here's a zoom because it's difficult to see them in that image:

    0_1476461438474_zoom.jpg

    Here's the material (the glass from bagginsbill's glass of beerprop)and my render settings - lighting is a diffuse IBL and an infinite:

    0_1476461515701_settings.jpg

    Any suggestions of what I shoulddo to get rid of (or minimize) them?


  • Poser Ambassadors

    @3dcheapskate - I'm sure I remember this issue being brought up before but quite unhelpfully cannot remember what the cause was. My suggestions would be -

    • turn off smooth polygons in render options
    • increase raytrace bounces to 4
    • increase pixel samples to 6
    • decrease minimum shading rate to 0.2

    Note that I would suggest keeping your render settings as posted & changing these one at a time to get comparison render. I'm not sure if any of these are the cause but that's where I would start - hopefully others will have better suggestions!



  • @caisson: thanks for the suggestions, which I'll try once I've had my sorely needed morning wake-up coffee(s). I'm sure that this has been discussed many times, and Ive just found a comment by bagginsbill on that glass of beer prop page, so I'll try ray bias too:

    "Raytracing through 4 surfaces is very demanding and requires extreme accuracy in handling the geometry and lighting as well as the refraction itself. Poser only recently [that's mid/late 2015] got a bug fix that makes the back-facing-polygon refraction correct, and there are always refraction artifacts at polygon boundaries with Poser. If you don't see them, you got the angles and settings right enough to make them unobvious. You might try increasing the Refract node's RayBias to reduce the black lines. However, if you go too far,the glass refraction will not see the nearby beer surface just inside, and all hell will break loose.

    Also, without gamma correction, any "black" artifacts will appear even blacker."

    But the artefacts I'm seeing aren't black, neither are they the Refract/Reflect background colours... ?

    N.B. There was a clear (pun intended! ;o) error in my render settings screenshot, because the renders obviously weren't done with a single raytrace bounce - I actually had it set to either 4 or 6. And smooth polys was only ticked for one of the three renders. I think I took the screenshot after closing Poser and reopening, forgetting that I'd changed those two settings.



  • New baseline test - same 12-sided cylinder mesh (with one level of PP2014 subd), same setup, and same material as before. Render settings as per screenshot (taken immediately after render this rtime!) 4 bounces. The fact that the meshline artefacts are red seems to indicate that the raytracing ran out of bounces on a refract node (and also that my original tests were perhaps with 6 bounces - I'll check that next). Note that the camera is pointing slightly downwards as before, so the majority of what we see in this render is passing through a single thickness of glass, and I'd expect just two bounces to be enough.

    0_1476503709272_bounce4.jpg



  • Everything the same as the previous test except I'm using 6 bounces. I guess this indicates I had 6 bounces for the original test.

    0_1476504011998_bounce6.jpg



  • Back to 4 bounces, but doubling pixel samples to 6.

    Looks the same as baseline (pixel samples set to 3) to me.

    0_1476504270291_pixel6.jpg



  • Baseline bounces (4) and pixel samples (3), min shading rate reduced to 0.2

    Looks the same as the baseline (min shading rate 1.0) to me

    0_1476504631914_minrsrpt2.jpg



  • Back to baseline, tried doubling the ray bias on the refract node.

    Looks the same as baseline to me.

    0_1476505090164_raybiaspt1.jpg



  • Maybe bigger changes? Baseline render settings again, refract node raybias 10 times the default.

    That's got rid of the artefacts (at no cost to render time, but need to be aware of bagginsbill's caution about not raising it too high)

    0_1476505333726_raybiaspt5.jpg



  • Try the same 'whack it up' approach with pixel samples - set to max (32). Don't forget to set refract node ray bias back to default (0.05) first!

    That doesn't fix it

    0_1476505803763_pixel36.jpg



  • ...and whacking min shading rate down to, not zero, but 0.01 doesn't seem to help

    Edit: looking at this image in comparison with the others, I think this has actually reduced to artefacts a bit.

    0_1476506627422_minsrpt01.jpg



  • How about a higher pixel samples (12) and lower min shading rate (0.1) together?

    Doesn't seem to help.

    Edit: similar to just whacking the shading rate down, this does actually seem to have reduced the artefacts a bit.

    0_1476506845750_pixelminsr.jpg



  • Actually with the default 0.05 ray bias on the refract (default as in 'as per the original material', not as in 'default for the refract node') and my baseline settings except raytrace bounces 6 and min shading rate 0.2 I think the meshline artefacts are almost unnoticeable

    0_1476507710110_success.jpg

    They're definitely still there (if you look carefully or zoom), but it's an alternative option to increasing the ray bias on the refract node.

    0_1476507829470_zoom.jpg



  • I'd guess that by increasing ray bias the artefacts would suddenly disappear, but by decreasing min shading rate they would gradually reduce. Not going to try that now - the aircon's on the blink and my laptop's going into meltdown ! Where's that bucket of ice water ?

    So either nudging Refract node ray bias upwards, or nudging render settings min shading rate downwards till the result is acceptable is probably the approach I'll take. Also probably ensure that the number of raytraces is a couple higher than the number of bounces I'd actually expect (having bright background colours for the Refract/Reflect nodes is a simple check I use. When everything else is good enough I can change those to black if necessary).



  • After draining the iced water out of my laptop I tried rendering the thing that started my current glass stuff, the screwtop part of a screwtop jar. Two versions, both 12-sided cylinders, but one with the thread modelled, and the other using displacement. One level of Poser subd applied to both (preview and render). Baseline render settings, except 6 bounces not 4. Same BB glass of beer material, but with refract node raybias set to 0.5

    The artefacts are only really noticeable on the displaced thread now - not really surprising that displacement adds an extra problem.

    I forgot to set the filtering of the background sphere image to 'None' so it's washed out as mentioned in another thread)

    0_1476515157790_screwtwo.jpg

    Edit: and here's the same thing with the just the background sphere image fixed (i.e. filtering set to 'none', as opposed to the default 'quality'). I think that even the displaced thread could pass muster on this one for a casual glance...

    0_1476515796494_filterfix.jpg


Log in to reply
 

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.