PP2014 - Meshlineartefacts on glass



  • Back to 4 bounces, but doubling pixel samples to 6.

    Looks the same as baseline (pixel samples set to 3) to me.

    0_1476504270291_pixel6.jpg



  • Baseline bounces (4) and pixel samples (3), min shading rate reduced to 0.2

    Looks the same as the baseline (min shading rate 1.0) to me

    0_1476504631914_minrsrpt2.jpg



  • Back to baseline, tried doubling the ray bias on the refract node.

    Looks the same as baseline to me.

    0_1476505090164_raybiaspt1.jpg



  • Maybe bigger changes? Baseline render settings again, refract node raybias 10 times the default.

    That's got rid of the artefacts (at no cost to render time, but need to be aware of bagginsbill's caution about not raising it too high)

    0_1476505333726_raybiaspt5.jpg



  • Try the same 'whack it up' approach with pixel samples - set to max (32). Don't forget to set refract node ray bias back to default (0.05) first!

    That doesn't fix it

    0_1476505803763_pixel36.jpg



  • ...and whacking min shading rate down to, not zero, but 0.01 doesn't seem to help

    Edit: looking at this image in comparison with the others, I think this has actually reduced to artefacts a bit.

    0_1476506627422_minsrpt01.jpg



  • How about a higher pixel samples (12) and lower min shading rate (0.1) together?

    Doesn't seem to help.

    Edit: similar to just whacking the shading rate down, this does actually seem to have reduced the artefacts a bit.

    0_1476506845750_pixelminsr.jpg



  • Actually with the default 0.05 ray bias on the refract (default as in 'as per the original material', not as in 'default for the refract node') and my baseline settings except raytrace bounces 6 and min shading rate 0.2 I think the meshline artefacts are almost unnoticeable

    0_1476507710110_success.jpg

    They're definitely still there (if you look carefully or zoom), but it's an alternative option to increasing the ray bias on the refract node.

    0_1476507829470_zoom.jpg



  • I'd guess that by increasing ray bias the artefacts would suddenly disappear, but by decreasing min shading rate they would gradually reduce. Not going to try that now - the aircon's on the blink and my laptop's going into meltdown ! Where's that bucket of ice water ?

    So either nudging Refract node ray bias upwards, or nudging render settings min shading rate downwards till the result is acceptable is probably the approach I'll take. Also probably ensure that the number of raytraces is a couple higher than the number of bounces I'd actually expect (having bright background colours for the Refract/Reflect nodes is a simple check I use. When everything else is good enough I can change those to black if necessary).



  • After draining the iced water out of my laptop I tried rendering the thing that started my current glass stuff, the screwtop part of a screwtop jar. Two versions, both 12-sided cylinders, but one with the thread modelled, and the other using displacement. One level of Poser subd applied to both (preview and render). Baseline render settings, except 6 bounces not 4. Same BB glass of beer material, but with refract node raybias set to 0.5

    The artefacts are only really noticeable on the displaced thread now - not really surprising that displacement adds an extra problem.

    I forgot to set the filtering of the background sphere image to 'None' so it's washed out as mentioned in another thread)

    0_1476515157790_screwtwo.jpg

    Edit: and here's the same thing with the just the background sphere image fixed (i.e. filtering set to 'none', as opposed to the default 'quality'). I think that even the displaced thread could pass muster on this one for a casual glance...

    0_1476515796494_filterfix.jpg