Lights on/off in Preview/Pose mode



  • Hi - hope this is an easy one for you guys...

    I've been working with a boxing ring set-up in Poser that has 8 lights on the ring including 4 corner spots, 2 wide areas and 2 low areas.

    Most of the time when I'm setting up poses I'm OK but I notice that some lights are not turned on in this view (even though they are when I render).
    Selecting a light will turn it on, but selecting another will turn the first one back off again...

    I've ticked all lights on 'Include in Open GL Preview' but this doesn't stop some lights from turning off. Is there a setting somewhere that leaves everything on whilst I'm setting up the pose?

    Thanks!

    RSK



  • OpenGL has a fixed max of lights showing. I can't remember if it's 4 or 6, but it's less than 8. So they won't show up in preview.



  • I believed that OpenGL can have 8 lights, no?



  • Thankyou Trekkie & Greg - that certainly saves me from wandering around the menus looking for a button to press... :)

    I think I actually have about 10 lights in my setup as there are 2 more that are not focussed on the ring. Looks like my best option would be to manually turn those off during posing - I really need to other 8 because I want to see how the boxing ring is lit.

    Thanks again,

    RSK.



  • If you have the option of Intel graphics on the motherboard. You could use that for the monitor.
    Intel has opted for a 16 light limit for their OpenGL implementation. (At least they used to, I don't know if more recent Intel graphics still have that.)


  • Poser Ambassadors

    The max number of traditional lights supported in OpenGl is 8.
    That is hard coded into OpenGl.
    Your hardware may not support 8 thou.

    Any lights past that, like in games, are not really lights per say.

    The Quake engine is a perfect example of this.
    It doesn't use any of the base OpenGl lights.

    Many times this is called Deferred Rendering.
    Basically lights (that are not really lights), that are all in the shaders



  • @rsk said in Lights on/off in Preview/Pose mode:

    I've ticked all lights on 'Include in Open GL Preview' but this doesn't stop some lights from turning off. Is there a setting somewhere that leaves everything on whilst I'm setting up the pose?

    Do you really need to have all the lights "on" while you're in in Preview mode? If it's a matter of needing more light to see what you're doing, you could add a fairly bright infinite or IBL light to the scene and set it up so that it doesn't show in renders, only in preview. To do that, just go to the new light's materials in the Advanced Material Room and turn the color chips next to Diffuse and Specular to black (but leave the Color chip white). Then you can do whatever you like with that light as you set up your scene, but the light won't be included in the render.

    This is basically the way to provide enough light to set up a scene when you're planning to use only light-emitting objects to provide light in an IDL render, but it works for setting up Direct Light renders too. I often use a 40% IBL w/ a round gradient (via procedural node) when posing figures, so that everything is lit up, even areas that would ordinarily be self-shadowed (like fingers).



  • @perpetualrevision said in Lights on/off in Preview/Pose mode:

    [...] a fairly bright infinite or IBL light to the scene and set it up so that it doesn't show in renders, only in preview. To do that, just go to the new light's materials in the Advanced Material Room and turn the color chips next to Diffuse and Specular to black (but leave the Color chip white). Then you can do whatever you like with that light as you set up your scene, but the light won't be included in the render.

    Thanks! I knew about that trick, but forgot how to do it!