Freebie: A Few Books By The Cheapskate...



  • @3dcheapskate most probably forgot to zero or cancel out a morph when spawning another. I've made a habit when spawning morphs of zeroing all deformer influence, then spawning a zero morph which I set to -1, then activate only the deformer I intend to spawn from, before spawning and then deleting the zero morph. The other thing I recently realised that I have to double-check, is that subdivision is set to zero before spawning any morphs, because the zero subdiv level deltas get miscalculated if the subdivision is active.



  • Well I finally got that resolved - it was all down to finger trouble of various sorts on my part.
    So I now have a PP2 where the bookrows do not unintentionally shift vertically when I twiddle the 'Randomize All BookSizes' and/or 'Shelf# Odds/Evens' dials. I put the bookrows prop into Seachnasaigh's bookcase again as a test and it seems okay now.
    0_1539913948841_InCase.jpg
    However, before doing the settings for actually fitting the prop to various bookcases I need to tidy up the PP2. I should have a maximum of 384 indices for each 'Shelf# Odds/Evens' but I actually have around 1500 due to a tiny offset that I missed. If I do a global find-and-replace in the PP2, load that in Poser, and then resave it from Poser it might automatically clear out the zero deltas...
    0_1539915356097_ToEdit.jpg



  • Yes! That actually worked- I didn't expect it to.
    I think I'll take a break now for the rest of the day (it's 9am here). Maybe start the fitting to different bookcases stuff this evening.
    0_1539915813980_YesItWorked.jpg



  • @3dcheapskate I'm just here to say thanks for using Edgar.



  • @3dcheapskate This is looking really good, well done!



  • @teyon said in Freebie: A Few Books By The Cheapskate...:

    @3dcheapskate I'm just here to say thanks for using Edgar.

    ...that'd be my new avatar/icon/thingumajig/whatever-it's-called you're referring to ? I only recently rendered him for the first time, arriving at an off-the-beaten-track fishing village. And that made me realize what a cool, sexy dude he is ! ;o)



  • @3dcheapskate Yup and glad you dig him. Ok, sorry, don't mean to derail. Carry on.



  • Okay, so I thought I'd got the mechanism for fitting the SixBookrows prop to a bookcase all cut and dried. A 'Fit To...' master dial that controls Scale, xScale, x/y/zTran, and some of my dials...
    0_1539954293201_AlmostButNotQuite.jpg

    That looks just about perfect. So I then parented the prop the bookcase...
    0_1539954363926_JumpsOnParenting.jpg

    ...what happened there ?

    (Note: all my master dials are created as 'targetGeom'channels with zero deltas and zeroindices, as recommendedin the BLRender book, because 'valueParm' channels don't get saved in pose files)



  • @3dcheapskate I think you just need to re-zero the xTran on the bookRows prop, which has acquired a non-zero value due to it's non-coincident origin with the bookcase when parenting, so the parenting logic puts the origin differences in the translation parameters, because it's being "helpful" ;-)



  • ...and here's a front view showing the actual bookcase parameters after the parenting.
    0_1539954672670_AfterParenting.jpg

    It's probably something straightforward, but that's probably about as far as I'll get today. Tomorrow I'll be travelling, and for the next week or so I may not get much chance to do anything more on this.(that's why I said "let's see how far I can get in five days" five days ago)



  • @anomalaus said in Freebie: A Few Books By The Cheapskate...:

    @3dcheapskate I think you just need to re-zero the xTran on the bookRows prop, which has acquired a non-zero value due to it's non-coincident origin with the bookcase when parenting, so the parenting logic puts the origin differences in the translation parameters, because it's being "helpful" ;-)

    Ah yes, that's part of it - Here's the bookrows parameters with that same front view:
    0_1539955124274_Bookrows.jpg

    And if I set the non-zero xTran and yTran back to zero:
    0_1539955176206_ReZero.jpg

    But the xScale has clearly been screwed up too



  • ...manually setting xScale back to 100 resolves that.
    0_1539955546255_ManuallyResolved.jpg

    That's a bit annoying because I really want it to be done with just the single 'Set To...' dial setting.



  • Had a chance for a quick look at this today.
    Found a solution (tested briefly in both Poser 6 and PP2014 - simply make sure that you parent the prop to the bookcase BEFORE setting the appropriate fitting dial. (Also, load a fresh prop to fit to a new bookcase - don't try using one that's already had any dials twiddled !) Two props, one parented/fitted to Seachnasaigh's bookcase, the other to the bookcase from DAZ 'The Study' (the prop goes through the central pillar, but looks fine)
    0_1540214357098_DoubleFitted.jpg

    I still don't understand the reason for the jump if you parent after setting the 'Fit To...' dial. The translation dials are clearly not set to 'compensate' for the difference between the bookcase/bookrows origins - they're set to exactly the same value as the fitting dial slaves them to, and thus they end up being simply double the slaved value. As for the xScale... :oS no idea ! Luckily, I'm not concerned about this any more.



  • ...and the prop works fine in DS3 - regardless of whether you parent to the bookcase before or after. So that's a Poser cockup.
    0_1540218522704_WorksInDS3.jpg



  • ...same in DS4 - you can parent before/after setting the dial:
    0_1540219805510_DS4FineToo.jpg



  • @3dcheapskate Looking very good indeed. :-)



  • Thanks. I'm almost there with this six-bookrows-in-one-prop thingy. I've put back the magnet for pulling out and tilting any individual book, and I'm doing a bit of tidying up on the alternative textures. I'm also playing around with it in Poser 6, PP2014, DS3 and DS4.9 to try and catch anything I've overlooked. Here's a PP2014 and DS4.9 render with the (modified, and still working on it) more classic texture:
    0_1540385989156_LatestTest24Oct9am.jpg
    0_1540386001239_LatestTest24Oct9amDS4-9.jpg
    You can see the materials need fiddling with in DS (as always), and the Shelf/Book Number dials which are restricted to integer values when spinning the dial in Poser are displayed as percentages by default and are only increased/decreased in 100% steps via the +/- 'nudge' buttons.
    I'm thinking I'll just put a note on the upload page and in the readme for DS users, because if I start to try and resolve the DS-specific issues...

    Also I've only found two large bookcases in my runtime. That surprised me.



  • Also another idea - small book groups. I've just seen a 21-book set of the 'Grolier Academic Encyclopedia', and recall that many of the leatherbound / halfleatherbound / fakeleatherbound 'classics' came in 'sets'.



  • Just discovered that in Poser 6 the magnets aren't deleted with the prop. In PP2014 they are, which is as it should be. Haven't tried any intermediate versions. Does anybody know what causes this, or even better - how to fix it ?



  • @3dcheapskate would you like to know how many years it's been since I was able to run Poser 6, or anything older than Poser Pro 2010 on macOS? Though I've never seen the movie, I still know enough from "Frozen" to suggest that you "Let it go" ;-)

    Trying to support what I'm pretty sure SMS won't themselves (of course Poser 6 is way prior to their acquisition) seems an exercise in... wait... aha! "Microsoft Thinking TM" ;-) Let's all be thankful that Poser now deletes deformers parented to props and figures being deleted, and no longer leaves them to clutter up the scene.

    The fix is, of course, stupidly simple (if not diplomatically so): upgrade to a later version of Poser! There will never be another patch for Poser 6 ;-)

    I do say this with tongue firmly wedged in cheek, since by dint of extreme personal stupidity, I managed to collapse all of the items in the hierarchy editor in Poser Pro 11, by clicking on the triangle next to the UNIVERSE actor, and thereby trigger the newest bug in the stable, inadvertently selecting the UNIVERSE actor and hanging Poser (which was different, since directly clicking on that usually just disappears Poser altogether). While I was futilely pretending to wait for PP11 to unhang itself (OK, procrastinating about giving it a SIGKILL), I opened up Poser Pro 2012 (I have license issues currently with 2014) to play with an OBJ I'd Blender converted from a Free SketchUp exported Collada DAE, that Poser consistently garbled.