Curve tool problem

  • Ive been having a problem since updating manga studio 5ex to clip studio pro ex with the curve tool snapping before I'm finished with it. It happens with my huion tablet and doesn't do It but about 50% of the time. It seams if I put to much pressure on the tablet the the curve just stops and snaps to where ever the pen is at the moment. Its driving me nuts. Ive reinstalled the graphics driver a few times already. Everything else with the driver seems to work. Ive also tried changing the tablet settings to tablet pc. Anybody have any ideas? I use the curve tool a lot in my art.

    Danny Garrett

  • Are any other tools behaving oddly as you apply more pressure to the tablet? The curve tool is really nothing more than a two point quadratic or cubic Bezier curve (or straight line without any handles). There aren't any pressure settings that can be applied to the tool. If the curve is ending it's because a release and click is taking place as you apply extra pressure (the release drops the second control point and the click is ending the curve and setting the handle placement) - like letting go of the mouse button and clicking it again.

    If you use the curve on a vector layer you would probably see that with a quadratic Bezier curve, the handle is being set right on top of the second control point.

    As an experiment to see what's happening, switch the Curve tool from using the quadratic Bezier curve to the cubic Bezier curve (open the Sub Tool Detail Palette to make the switch). With that type of curve, you would lay down the first control point when the pen touches tablet then you drag to the position of the second control point and release to lay the second control point down. Then you would hover the cursor over the tablet to find the position of the first control point's handle and click the tablet with your pen to set it, then you hover the cursor over the tablet to find the position of the second control point handle and click the tablet to set the handle of the second control point, ending the curve. If your tablet is doing some kind of release/click with extra pressure then the second control point will get laid down and the handle of the first control point will be set right on top of the second control point but the curve won't end until you click again to set the handle of the second control point.

    If extra pressure is causing a release/click I'm not sure what you can do. You would need to check with Huion forums to see if anyone else is experiencing this sort of behavior and find out if there's a fix.

  • I have a Huion 610 Pro tablet and it sometimes drops my curve endpoints at random when moving the pen also. It seems to be a driver issue. The point dropping behavior usually repeats if I retry the curve tool operation. When it happens, I move on to other vector operations and come back to the curve tool. That often clears the issue (at least temporarily).

  • I'm having the exact same problem. It happened as soon as I upgraded from El Capitan to Sierra (MacOS). I've since tried the latest update to CP (1.6.2) but the problem persists. Have you had any luck with finding a solution (are you on Mac or PC?)

  • @aaron I have the problem on Windows 10 using the latest Huion driver. I've disabled Windows 10 Flicks and Press and hold features. Both Clip Studio Pro 1.5.4 and 1.6.2 are affected by this issue on my PC.

    There are other stylus-related issues that aren't as noticeable when using brushes or pens/pencils. Vector tools that require moving the stylus and registering points is the most affected operations in my case (curve and ellipse tools). The Huion driver stops registering stylus positioning and then restarts, causing Clip Studio to respond as if you completed one operation and started another.

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.