IDL in Poser 11: a step back from Poser 10



  • @englishbob

    Hi there

    I forgot to say,I'm comparing Pro versions,I've done 4 renders with all same settings,I didn't changed anything
    Hard to say what i would recommend to do,all depends there,if you are happy with Poser 10 renders then I would stick with P10 and use P11 for different projects as I do,some renders I'm rendering in 10 and some in 11

    Hope this helps

    Thanks,Jura



  • @jura11 said in IDL in Poser 11: a step back from Poser 10:

    I forgot to say,I'm comparing Pro versions

    Interesting - so you're saying Poser Pro 11 renders the same scene faster than Poser Pro 2014?

    some renders I'm rendering in 10 and some in 11

    What are your reasons for doing this? What does 10 do better than 11 - for you?



  • @englishbob

    Hi there

    Some scripts don't work in Poser 11 what I've tried,plus Library in Poser 10 is much better,I don't like too much Poser 11 Library,but with some tweaks is pretty much good for me,but still I prefer 10

    And as you said,artifacts,subdividing mesh is good,but if you have larger scene with few figures and several props then for me is no go,still Poser don't have best management of scene and is pain,sometimes I need to export in Poser 10 figures as OBJ and re import them back to lower poly counts

    I've done in Poser 11 render of my older scenes and projects and I've saw artifacts sometimes where I've never seen previously and been with that puzzled and then tried same scene in 10 and no artifacts or some artifacts,but still no as many as in 11

    I will try to post my simple scene which is for FF with render times and can compare that

    Hope this helps

    Thanks,Jura



  • @jura11 : thanks, that will be very helpful.

    Actually, I prefer the Poser 11 library. ;)



  • @englishbob

    Here are my tests,just quicker

    Poser Pro 10 rendered this in 4 minutes and 1 seconds

    alt text

    Poser 11 rendered same image in 196.44 seconds which is 3 minutes and 27 seconds

    alt text

    In both scenes and renders I've used same render settings and same light setup etc,I didn't changed anything

    Hope this helps

    Thanks,Jura



  • @jura11 said in IDL in Poser 11: a step back from Poser 10:

    Here are my tests,just quicker
    Poser Pro 10 rendered this in 4 minutes and 1 seconds
    Poser 11 rendered same image in 196.44 seconds which is 3 minutes and 27 seconds
    In both scenes and renders I've used same render settings and same light setup etc,I didn't changed anything
    Hope this helps
    Thanks,Jura

    Thanks! Flicking between those two images, I can see differences, but they're small. I'd be happy with either of them. Is this using your light rig with two infinite lights as mentioned before?

    The speed-up in the Poser 11 render may be a sign that some optimisation has been done.



  • @englishbob

    Hi there

    Yes there are small differences,in both cases I've subdivided dress to 2 and rendered that,renders are pretty much same,although I will do test without the subdiv later on
    Yes I'm using same light rig,two infinite lights with low intensity(I think 15%) plus BB EnvSphere and that's it

    Speed difference is not so high as I would thought so,but still at least there is some speed up at least

    Hope this helps

    Thanks,Jura



  • @jura11 said in IDL in Poser 11: a step back from Poser 10:

    Hope this helps

    Yes, thanks!

    Yes I'm using same light rig,two infinite lights with low intensity(I think 15%)

    I used 15% when I copied your set-up, but it seemed quite bright.

    Speed difference is not so high as I would thought so,but still at least there is some speed up at least

    That's fine, it means I won't lose too much by rendering in Poser 10. I can do most of my work in P11 and go to 10 for final renders. (Because I refuse to install Flash, I can't use the Poser 10 library - so P10 is less easy to use as well as being slower.)



  • @englishbob

    Hi there

    Here is my light setup uploaded there,with EnvShere HDR

    https://www.dropbox.com/s/loazxx6hwyctbsz/FF Light setup.rar?dl=0

    Both lights are with shadows enabled and I think they have 32% intensity,but I would check that

    Hope this helps

    Thanks,Jura



  • Thanks again! The light intensities in your set are 32% and 28%. The key is the envsphere HDR which cuts down the amount of reflected light. I was using plain white which I suspect tends to amplify the lighting.



  • @englishbob

    Hi there

    Sorry, for not posting this setup and HDR sooner, its sometimes hard to replicate someone light setup

    I usually use that setup for portrait renders in FF and in SF I use similar with two area lights, sometimes I use 3

    Just in Poser 11 and FF don't use Area lights, because they will slow down rendering, on other hand in SF are probably best and I prefer to use them

    In few renders I've used only spot lights for portrait scenes and they worked pretty much OK

    I will try to make few renders to show you differences between two of the light setup, point lights I use rarely, not sure why

    Wish we have or could use IES profiles and have proper mesh lights like in other SW

    Hope this helps

    Thanks, Jura



  • @englishbob said in IDL in Poser 11: a step back from Poser 10:

    The speed-up in the Poser 11 render may be a sign that some optimisation has been done.

    The ray accelerator was upgraded, which improved performance for many scenes. It should not have caused the type of issue you're describing though.

    We're unable to reproduce, could you please file a ticket via https://support.smithmicro.com and provide a collected scene that does? Ideally it would be just the dress, or something even simpler if that is possible.

    Thanks!



  • @ghostship said in IDL in Poser 11: a step back from Poser 10:
    ..

    Sir, we have a warrant for your arrest. LOL.

    That's fine. Put it in my In-Box with all the other ones... :)



  • @englishbob said in IDL in Poser 11: a step back from Poser 10:
    ...

    You can see the blotching where the folds in her skirt are. The difference between our scenes is that your dress is close fitting and doesn't have folds. I think the Poser 11 IDL algorithm is going wrong when it has to deal with areas which are both curved and not well lit.

    Somewhere on the way from the previous version to the latest one it got broken.

    What are your light settings?

    I know we all run to D3D's awesome render panel, but all-too-often I see people ignore posting their light settings, which are arguably more important in some instances.

    (I haven't had a chance to check Jura's included lightset file, yet.)



  • @Uli-Klumpp said in IDL in Poser 11: a step back from Poser 10:

    The ray accelerator was upgraded, which improved performance for many scenes. It should not have caused the type of issue you're describing though.

    We're unable to reproduce, could you please file a ticket via https://support.smithmicro.com and provide a collected scene that does? Ideally it would be just the dress, or something even simpler if that is possible.

    I'll try. I don't have hard evidence, but I have the impression that the contents of the scene have a bearing on the artifacts, even though they may not receive any blotches themselves. At the moment I'm trying to create a distributable scene that shows the effect strongly.



  • By Jove, I think I've got it. The trigger - one trigger, anyway - seems to be having 'Smooth Polygons' enabled in the render settings. This produces many more artifacts in Poser 11 than it does in Poser 10.

    Summary of render results

    This gives me a relatively simple, distributable scene that I sent to Smith Micro when I raised a support ticket:

    http://www.morphography.uk.vu/public/TestScene.pzz

    Everything in there was made by me, so you can do what you want with it. Even if you aren't interested in the rendering issues, there's a dynamic sports dress in there which you're free to use as you wish. It fits Antonia. Think of it as your reward for ploughing through all the verbiage. :)

    As others have said earlier in the thread, applying subdivision to the dress does sort out the blotches in this case; it isn't a universal fix. Some objects I've tried break up if I apply subdivision to them, and of course there's also the question of impact on computer resources, and hence rendering time, if the result of subdiv is lots of polygons.

    You're welcome to try the scene for yourselves, with whatever settings you choose. I don't wish to appear grumpy, but I'm not particularly interested in hearing advice on how to work around this problem; I have a work-around already. However others may stumble across this thread, and they may be interested, so have at it if you feel so inclined. :)

    As I said, a support case has been raised as recommended by @Uli-Klumpp. Maybe in the fullness of time there will be an update which fixes it. My fingers are crossed, which is why my typing is so erratic. :)



  • One more off-topic thing, while I remember. If I open a URL that points to a compressed Poser file in any browser, plain text is displayed.

    Edited to add: you can also just drag-and-drop the file onto a new window in your browser. There's no need to upload it.

    Browsers know about Gzip compression and automagically uncompress it. That may be worth knowing if you need to uncompress a file and don't have access to an application to do it for you.



  • @englishbob can you zip that file up before uploading? All aI get is a text file. After changing the file extender to .pzz it gives an error when you try to open it and does not work.



  • @ghostship said in IDL in Poser 11: a step back from Poser 10:

    @englishbob can you zip that file up before uploading? All aI get is a text file. After changing the file extender to .pzz it gives an error when you try to open it and does not work.

    Just right-click on the link and choose 'Save link as...' or whatever equivalent your browser offers.

    Alternatively if you save the text file, change its extension to .pz3 since it's no longer compressed.



  • @englishbob Got it working.

    As other have said, 1 level of Sub D and it looks fine. In fact, just turning off smoothing fixed the problem.

    0_1479313221044_1lvlSubD.jpg