Clip Studio Keeps "dropping down"



  • I'm not sure if I phrased this question correctly but Clip Studio keeps getting superseded by other open applications as if I had accidentally clicked them with the curser between thirty seconds to a minute of work. (Which I didn't) It seems to do it less if they're hidden (or if there's nothing else open) but since I sometimes need to have them available I'd like to know if it's something I set in the preferences. Any thoughts It's making getting anything done difficult.



  • Not experiencing this on my Mac (Sierra -- MacOS 10.12.1). Would be helpful if you included your Operating System and other hardware data.



  • @cartoonMike That's what I have too.



  • @monsanto On a side note I tried to see if turning off all of the applications to see if that would make any difference. Regrettably this still continued happening with the finder. To a minor extent I could sort of ignoring this because there was the canvas was still visible. However when this happened It was almost as if the canvas was transparent and I found myself clicking on items on the dashboard that were "underneath" the canvas.



  • I would see if this is happening with other graphic apps (like Corel Painter, Photoslop, Sketchbook, etc)

    You could see if Activity Monitor (it comes with MacOS, check the Utilites folder inside the Apps folder) has any processes that are hogging the CPU.

    You could restart CSP with the shift key held down (this will reset preferences and start CSP with those defaults) and see if that helps. You may want to write down the settings (or screen cap 'em) for reference to change them back.

    Depending on other answers you get, you may want to go drastic and just delete and re-install CSP (make sure you have your serial number, just in case) after exporting any custom brushes & materials as you will have to re-do them and re-import the brushes and custom materials afterwards.

    Now it could be something the MacOS is doing. If you have a way, check network traffic on your mac, sometimes uploading a boat-load of photos or files to iCloud will drag your system down and make it seem like it's wading through molasses while dressed in a lead suit. This bit me when I accidentally had my desktop and document folder automagically on the iCloud. My system was a bit draggy for a few hours. And when my photos were being uploaded, that drag lasted for a few days ymmv

    When you say "superseded" did you see the Dreaded BeachBall of Doom? That's a good indication that the Finder is busy, busy, busy. Sometimes when a new version of MacOS is installed the Finder's memory expands way too much and things start to slow down. In my experience, deleting the Finder's preferences does help. Then I set up the prefs not to include the iCloud in the Right sidebar (blanking on what it's called exactly, but it's the bar on the right side of windows that includes your hard drives, app folder, downloads folder, etc). And then in Window prefs don't include the "size" attribute.


    IF you want to here's what to type into (or you could copy and paste it into the terminal box (do this ONLY if you are sure you want to. Do a bit of research, cuz you can do some serious mischief with it):

    rm ~/Library/Preferences/com.apple.finder.plist&&killall Finder

    This will delete finder preferences and restart the finder in a "pristine" condition -- so be sure to change the prefs back to what you want them to. Sometimes I found to make the changes "stick" it's best to restart the Mac.
    Hope this helps, or at least gets you going down a path to solve the issue.



  • At the moment the only other drawing software I have is Photoshop and, besides occasional sluggishness, it’s not having this problem. I checked the activity monitor and I’m not sure if I’m good at reading it, but while CPS runs high, it's a fraction of Photoshop which is working fine.

    I did the reset. It seemed to help briefly but the problem started again after a couple of minutes (on another note a friend suggested it was a problem with with the settings on my tablet (leaving touch on) but this didn’t help.

    Your suggestion of iCloud was valid since I’d just gotten a new WDmyCloud and i’d just started backing up my archives. But this problem had started before I was doing this and did not stop after the last batch I done. (perhaps my hard drive getting close to full (366GB left at the moment) might be an issue.)

    What I mean by “superseded” (and I freely that was not the best word) is that after I’m working for up to a minute I’m suddenly on the last application I was using (at first I briefly thought CPS had crashed until I found it was still open. But after going back the process is repeats itself. Sometimes it briefly acts as if the canvas is transparent and I find myself clicking on things underneath it before it goes back to the other application. At the moment this is rendering CPS useless.

    It may come to having to do areinstallation, but i’d like to get a decent diagnosis before I do something that drastic. (I don’t want to have to do it too many times after all)



  • What drawing device are you using? I'd suspect it has to do with your tablet. Try unplugging it and just using your mouse and see if the same thing happens.



  • Hey, I'm having this same problem.
    I'm using a Wacom Cintiq 22HD and just upgraded my Mac to OS Sierra. I also updated my Wacom driver, thinking that might be the issue. Just got off the phone with Apple and we decided it must be an issue with CSP since it's the only program that is being effected by this problem.
    This is driving me crazy and I have things to finish. Please help!



  • I haven't had any trouble with Sierra. Tried it first installed on a partition and then ended up upgrading my existing one. Try renaming your CSP folder in document, and then delete and reinstall CSP from scratch. If it works then, you can try your old older to get your shortcuts and settings back.



  • One thing that you could try is in Preferences|Tablet|Tablet Settings set the priority for Process to different values. I have an Yinova tablet and it's set to 3. Don't know if it'll help in your case, but it's worth a try.



  • Just following up on some of the suggestions I tried unplugging my tablet (intros5 touch) and drawing with my mouse. I couldn't go 15 seconds with the drop. then I tried multiple settings on the Preference/Tablet option with even less luck.



  • Also, I've noticed I have the same problem with the copy on my laptop to a lesser extent, but at least with that one turning off all my other applications works.



  • So I noticed that I hadn't updated CSP with the update released in March and so I gave that a go. So far so good. I've been sketching for a while now with no problems. Monsanto, hopefully this works for you, too, if you haven't already tried it.
    Thanks for the help everyone!



  • Based on this advice, backed up by similar advice by tech support I just installed the update. Everything seems to be working so far....



  • I have the exact same problems that monsanto is having and I have a Mac Mini running Sierra. I have my Wacom Cintiq set to have all touch interface disabled, and extra menu stuff disabled, buttons etc. I just want the basic functions of the pen to work, but I can only get a few brush strokes in before the previously used app jumps up in the foreground. I have tried new drivers and all the usual like unplugging and logging out. My wired mouse does not have the same problem, it really seems to be the pen tablet in Clip Studio. I have only the Finder open. I just tested Affinity Photo just now, and the pen tablet seems to work fine there.



  • @agamemmnon58 Did you do a "clean" update for wacom? Ideally, you should back up your tablet prefs and then delete the entire Wacom table driver & such. There should be an app in the wacom folder named "remove wacom" or some such. When I was using a wacom, I had issues with it but when I started saving the prefs and removing and then installing the update "fresh" the issues vanished. If you're still having issues, then maybe something in the stylus is bad, would suggest asking Wacom for assistance in that case.



  • @agamemmnon58

    Hey,
    I was able to fix my problem by upgrading to the newest version of Clip Studio. This problem seems to pop up with every new upgrade, but it's easy enough to upgrade so it's workable. Still kinda annoying, but workable.

    I hope this helps, good luck! :)



  • @spollak, I just bought this today as a download from Amazon, and I just naturally assumed it was the latest version. Apparently I have 1.3.1 and the latest on the website is 1.6.2. I am brand new to Clip Studio Paint, how do I get this latest version? Are version upgrades free?



  • @cartoonMike
    I tried the Wacom deletion tool and did a fresh install. No luck... AND also that this is a pretty basic Intuos tablet. NOT a Cintiq! I must have wishful thinking. :P



  • @agamemmnon58
    Luckily I see that the new one is a free upgrade! Downloading now.. hope this works. In the meantime, I think I need to also upgrade my tablet too!