Protip: Why morphs break in the cloth room

  • I'm running a little project to convert various Genesis clothing into Poser dynamic cloth. Some of the pieces include useful morphs, and I'm trying to incorporate them too. I'm using Dimension3D's DSF Toolbox which has a batch processing facility so I can extract several morphs in one go.

    However one dress had me puzzled. If I added morphs to it, as soon as I selected it to be clothified, all the morphs would zero and the dials stopped working. Even if I deleted the cloth simulation, they never worked again... (Cue spooky music.)

    After much prodding about with the mesh, it turned out to be un-welded vertices. I believe that Poser welds a mesh before it's simulated, which I wasn't previously aware of and is useful in many situations. As long as I weld the clothing mesh and all the morphs that I want to use, it works fine.

    Tech note: this happens because, once welded, the cloth mesh has fewer vertices than there are morph deltas, and Poser is programmed to ignore morph dials if that is the case. This is how alternate geometries with different vertex counts can have their own set of morphs.

    Here's the result, Slim McKenzie's free Spring Dress for G3F fitted to V4. I've asked him if he wants to distribute conversions himself, or allow me to do so. If he agrees, I'd like to convert for some figures that don't get as much clothing support.

    I used the 'longer'. 'wider' and 'neckline' morphs in this scene.

    Spring Dress

  • Poser Ambassadors

    Yes, the cloth room only works optimal with fully welded obj files.

    What you can try is;
    Export the dress (in its zero pose)
    If you have the "raw" obj file, use that one...

    Then fully weld the dress in an external 3D app (Blender can do that), and then do a "copy morphs from" in Poser before or after you run the cloth simm.

    idea's to try out.

  • @englishbob said in Protip: Why morphs break in the cloth room:

    ...I believe that Poser welds a mesh before it's simulated...

    No, that's not true - strike that and put the spooky music back on. I tried this with a different un-welded mesh, and it didn't break the morphs.

    I need more data. One out of two isn't statistically significant either way. :)

    This happens with the Spring Dress in all the Poser cloth rooms I have handy, by the way: 6, 7, 10 and 11.

  • You can try, after make all changes you want and you get the final mesh you want to use in the cloth room, open that figure and the original one, and use the "copy morphs from" and copy the morphs of the original figure to yours.

  • @englishbob said in Protip: Why morphs break in the cloth room:

    ...I believe that Poser welds a mesh before it's simulated...

    No, that's not true - strike that and put the spooky music back on

    No, I've realised this when trying to clothify jeans. They always, always result in the belt hooks falling off. Basically, ay model that is created using what would show up in 3DS Max as separate elements, will misbehave when clothified.

    My 3DS solution is to take the item back into 3DS and use the attach command. If that doesn't work, you can weld vertices, but you need to be careful because if the vertice count OR order changes, any morphs you wanted to apply will no longer work.

  • Thanks to all for the replies. I had better try to explain what I'm doing, because everyone has unfortunately missed that point.

    I should also see about having the thread title changed, since I really thought I'd found something interesting when I posted. Instead of that, it's just a piece of typical weirdness.

    The morphs I'm referring to are styling morphs that can be applied before cloth simulation. For example, the dress I showed has a morph that makes the skirt longer. Obviously this needs to be applied before simulation, and it's this that is breaking.

    I'm not so concerned personally with figure shaping morphs, and I'm not trying to transfer them from the figure or anything like that. By the way, the 'copy morphs from' function is Pro only, and I don't have the Pro version.

    So far, this dress is the only mesh I've found which is welded - automatically by Poser - when I clothify it. I have no idea why. I've tried other meshes, and made my own test pieces, and none of them do this.

    At least, now I know what causes the morphs to break, I can work round it if it happens again. Hopefully this information may be useful to others who search for answers in the future.

Log in to reply

Looks like your connection to Graphics Forum was lost, please wait while we try to reconnect.