Rendering cpu usage setting


  • Poser Ambassadors

    Repeating (almost) a post by me from another thread:

    https://forum.smithmicro.com/topic/1979/pp2014-ffrender-hogging-resources/7?page=1

    ^^^^^

    Thread reduction is one way to free up CPU but not the best. The best ... is to just lower the priority of Poser so it gets all the CPU except when ANY other program wants some, then it doesn't. This way, if you're just reading a web page doing nothing, Poser uses 100%, but the millisecond you click a link to go look at another web page, all the CPU goes to the browser, until the browser is once again idle. In other words, by lowering the priority of Poser, you set it to "borrow" CPU instead of "own". Any program that is doing work on your behalf will take it back from Poser until it doesn't need it.

    To set this up "permanently" I changed my desktop shortcut. Edit the Target field like this (but use your own correct paths of course)

    C:\Windows\System32\cmd.exe /c start "Poser" /belownormal "C:\Program Files\Smith Micro\Poser 11\Poser.exe"

    Rendering in a separate process can free up the Poser UI, but the renderer is still "owning" and not sharing nicely. Change the priority and it only borrows, whether you're doing foreground or background rendering.

    ^^^^^

    Read the full thread for more info - note that Poser 11 background or separate process may already change to low priority on its own, but the regular foreground renderer does not seem to.



  • If windows was installed with one processor in the machine, then the second one added. The HAL will need updated to use more than 50% cpu resources.

    Try this first thou...

    1. Press WIN+R, type msconfig, press Enter.

    2. System Configuration --> Boot --> Advanced Options --> uncheck "Number of processors" and also uncheck "Maximum Memory" . Click OK and reboot.



  • If that doesnt work, I would need to know what motherboard and memory you have.



  • @bagginsbill thanks for your answer !

    You know, (i'm sure you already know) that all your posts should be sanctuarized.
    i'm not trying to polish your self esteem, you're the kind of person that is a proof of how people can be nice and humble :)

    I already succeeded to sanctuarize all your renderosity posts, but it's much less simple on smithmicro.com.

    It's amazing how when you think you already nicely tweaked your poser configuration, they're always something else you can do ... It should be the leitmotiv on poser jacket ;)



  • Thanks for all the reply Guys. I really appreciate that. I will try all the method you guys teaching me above. Now i m doing the method wrote by vilters, but not yet found the poser.ini . Anyone can tell me which folder to find it ?



  • @momogun if you open the Poser Python Shell, and type:

    >>> poser.PrefsLocation()
    

    it will print out the path in which the Poser.ini (on Windows, "Poser Prefs" on macOS) file resides; usually relative to your user account.

    From p1041 of the Poser 11 Reference Manual:
    0_1541419423523_Screen Shot 2018-11-05 at 11.02.55 pm.png



  • @anomalaus this is awesome.. Thanks



  • @vilters Had follow you advise. Had change the Render Treads in poser.ini to 80. When i go back to poser i found the render thread become 80 and no longer 32. But when i clicked to adjust THE THREAD AMOUNT. The max render thread suddenly back become 32. A bit of improvement, now when i doing rendering the cpu usage become 57% compare to last time only 47%. Any Other advise how to fix this ?



  • @shvrdavid i had checked the system configuration --> Boot --> Advanced Options --> and found out the Number of processors and ram never been ticked. Had try to tick them and reboot. And go to poser doing rendering, result still same. Had go back to --> Boot --> Advanced Options and unticked the number of processor and ram then reboot. but rendering result still the same. For you info during i install poser my system only 1 processor in it. My mother board is supermicro x11dph-i. Ram is 32 Gb (4X8GB) PC4-2133P-RCO-10.



  • @momogun said in Rendering cpu usage setting:

    supermicro x11dph-i

    Just out of curiosity, can any other program use all of the cpu resources?

    IE: Maxwell render test, Cinebench, etc..

    If not, go to the bios and make sure the UPI settings are correct.



  • @shvrdavid what is UPI? Had check in bios but not found any option for UPI setting.



  • 0_1541598098481_DSC_0208.JPG
    This picture is a rendering process with task manager on it. Seem windows detected 40 cores 80 thread and 2 socket of processor. As you can see, only 57% of the cpu used by poser.



  • @momogun The UPI settings are for the number of physical processors.
    It's on page 79 of the downloadable mother board manual.
    Normally it would be set to auto, but you never know.
    There are some odd settings on the Super Micro boards for cpus.
    If they are not on auto it can mess with the number of usable cores.

    I don't have a machine that has more than 32 threads.
    I am starting to wonder if maybe Poser isn't coded to use past 32.
    That is why I asked if other render tests can use all of the cores you have.
    If other render tests can use all 80 cores, then you have your answer.


  • Poser Ambassadors

    57% of 80 is around 45 logical cores working full time. That doesn't feel like 32 is the reason.

    My guess would be that objects or collections that must be shared by the threads are sufficiently in contention that a significant number are waiting on a mutex. 80 threads operating on common data is starting to get into a class of programming that is very new, and probably not the style in which Cycles operates. For massive parallelism, you have to go with new data structures. But like I said, I'm just guessing.

    A few minutes googling, I could not find an example of anybody using Cycles in Blender with more than 16 cores.


  • Poser Ambassadors

    Blender on 80 cores
    The dual Xeon Gold 6138 setup was the fastest to little surprise considering it has 80 logical cores in total while the EPYC 7601 tops out at 64. Worth noting with these numbers though is the Threadripper 1950X competing very well with the Core i9 7960X, which costs much more than this current top-end Threadripper CPU. The Ryzen 7 1800X manages to beat out the Core i7 8700K Coffee Lake CPU in this scene.


  • Poser Ambassadors

    @momogun

    What I would do to check the system and operating system is to duplicate that test in the link I added above and see what CPU% you get on your system.
    Troubleshoot from there.



  • Thanks for replying guys. I will try to follow all of the advise above. Will let you know If any update.


  • Poser Ambassadors

    @vilters said in Rendering cpu usage setting:

    Blender on 80 cores
    The dual Xeon Gold 6138 setup was the fastest to little surprise considering it has 80 logical cores in total while the EPYC 7601 tops out at 64. Worth noting with these numbers though is the Threadripper 1950X competing very well with the Core i9 7960X, which costs much more than this current top-end Threadripper CPU. The Ryzen 7 1800X manages to beat out the Core i7 8700K Coffee Lake CPU in this scene.

    That's a data point but doesn't say anything about whether or not the 80 cores were 100% in use. It just may be that they were collectively 57% in use but 57% of 80 is surely faster then 100% of 32, for example, unless the 32 cores are using a higher clock or better cache or a hundred other things. So that doesn't inform us at all whether cycles/SuperFly CAN effectively run 80 threads without them arguing over resources.



  • I would like to ask you guys. In you computer, what parts you need to upgrade the most to make the animating process run smooth(no frame skip) during animating 2-4 characters at the same time. Is that the processor clock speed or highest number of core, or Graphic card or what ?



  • For you info my new computer with dual Intel Xeon Gold 6138 processor (40 cores and max turbo 3ghz), ram 32gb, Vga Card quadro m4000 not run smooth during animating even a single character. My old Computer i7 5820k processor (6 core, 3.3 ghz) Ram 32gb, vga card quadro k2200 run more smooth than my new pc.