Older poser content not seen by Poser 11Pro-



  • Hi
    I added the Runtime from Poser 6 (where I kept everything up to PoserPro2012). 11 only sees newer content-not even seeing Victoria 4. I tried the Python Script "Import Runtimes2014" but it seems to be looking for a file-not a Runtime Folder.
    Any help would be appreciated! I was a beta tester for Pro2012 and I seem to remember there is a trick to getting it to SEE older files.
    Any help is appreciated!



  • @pelagius I will assume that the folder you selected was the one which contains the Poser 6 "Runtime" folder, not the Runtime folder itself.

    When you say you can't "SEE" the files in that runtime, do you mean that the folders in the hierarchy are visible in the library, and that they contain nothing, or that the library items have no icons except for the Shrugging Man?

    Are you on Windows or MacOS? Later versions of MacOS no longer have built-in support for displaying some of the older .RSR style icons that Poser 6 era files used, before everything went to .PNG icons. There are (or used to be) some utilities for converting .RSR icons to .PNG, but I'm not sure whether that's your issue, yet.

    The Import Runtimes 2014.py has, unfortunately, not been updated for Poser 11 (so it won't look for Poser 2014 runtimes). If it does not find preferences for an installation of Poser from versions 7 through 2012, it will ask for the location of the Poser.exe application (not even accounting for there being no such file on macOS). It doesn't actually care what file you select, though, since it is only using the path of that selected file to determine where to look for the LibraryPrefs.xml for that Poser version, since prior to Poser 7, the preferences lived within the Application's own folder hierarchy, rather than in the User's preferences locations.



  • @anomalaus said in Older poser content not seen by Poser 11Pro-:

    There are (or used to be) some utilities for converting .RSR icons to .PNG, but I'm not sure whether that's your issue, yet.

    I found P3dO years ago at Sensofoft. There's the free version I use, mostly for converting RSRs to PNGs, but a good many folks use a lot of the other options, especially those contained in the Pro version.

    3Pd0 at SensoSoft

    Also Yarp has the lastest Pro version up in the store at Renderosity.

    P3dO at Renderosity



  • @anomalaus Hi
    I am on MacOS Sierra.
    It finds and adds the Runtime. It's just that it only finds a few of the items inside-instead of hundreds going up to the Poser2012-2014 era. I CAN see them in finder-but Poser 11 does not.
    This includes many morphs and textures made for V4-some by me in Zbrush-as well as many textures. It finds a handful that were purchased in that era. I don't mind not using the P4 people-but I have many V4 characters and textures as well as many fairly complex Node setups.



  • @pelagius I'm also sticking with macOS Sierra for the moment. My mid-2011 27" iMac is currently unsupported in Mojave (though I'm sure someone will come up with a hack). I'm really keen to avoid the disaster zone of Poser not currently supporting APFS volumes on SSD for sorted content in libraries and recent renders, so I'll certainly be waiting for that to get sorted before I upgrade OS again.

    Quite some time ago, when I was running out of space on my boot drive (as is almost always the case), I moved a large number of old Poser runtimes to another hard drive. I noticed immediately, that Python scripts (not so much the Poser libraries) had trouble negotiating Apple Finder aliases, which are almost, but not quite, unix soft links. Prior to OS X, soft links did not exist, and the Finder was the only filesystem game. Python deals with unix level filesystems, so automatically handles soft links, but has to jump through hoops to deal with Finder Aliases. Since OS X, the Finder now understands soft links, so they can be used to move folder hierarchies to a different filesystem on another drive, whereas Finder Aliases (not to be confused with unix shell aliases, which are just a shortcut token for a fully qualified path) can be understood and traversed by any software that uses the Finder API (standard file dialogues), but generally not by python scripts.

    It might be worth checking whether the Runtimes Poser is having difficulty finding files in have been relocated with a Finder Alias.

    Can you show what's in your LibraryPrefs.xml file?



  • @anomalaus Hi! Where do I find the Prefs file? BTW: it does see some newer files that were in the same Poser 6 Runtime.
    I'd been using the same Runtime for various versions- Poser6, PoserPro, Poser Pro2010, 2012, and 2014 all on a 2006 MacPro.and all using the Poser 6 Runtime folder.
    The only difference is that I am now on a newer computer having moved from a 2006 MacPro to a 2012 MacPro in late 2014.
    So to be clear- Poser11Pro does see a few things-likely installed in the old Poser 6 Runtime.



  • @pelagius I found the prefs following directions here: https://forum.smithmicro.com/topic/9135/macos-mojave-compatibility/2
    See my comment toward the end.



  • @willshetterly Hi! It seems that if I directly copy paste my files from the Poser 6 runtime-into the Poser 11 Runtime-they appear.



  • @pelagius
    0_1543153902119_Screen Shot 2018-11-05 at 11.02.55 pm.png
    if you type:

    >>> poser.PoserPrefs()
    

    into Poser's Python Shell, it will display the path where the LibraryPrefs.xml should be located.



  • @anomalaus Thanks! I seem to have solved my issue by copying all my various and sundry items from my Poser 6 Runtime to the Runtime created by Poser 11 Pro. IE, Geometries, Libraries-Textures, Characters, etc. Thanks for your help on finding the Prefs file. Not sure what I could have done to edit it to SEE the older files in it's original location. Once I physically copied them into the Poser 11 Runtime they were all workable and visible. I don't really use much content from the RSR era.
    Somehow Poser11 saw (meaning the files were present) the few Genesis 2 items in the original Poser 6 Runtime location and NONE of my Poser Content-until I Copied it to the Poser 11 Runtime created during installation. Luckily as a user since Poser3 I am familiar with how to do that!