Michael 4 and POSER 11 Pro



  • I'm really very confused and angry. Yesterday I bought the Michael 4 basic package for $ 29.95. I use Poser 11 Pro.
    For Poser, a method to install is missing in the 4 zip file.
    All of this is really bad and represents a bad service from Daz!
    What should I do to install Poser 11 "Michael 4 Base" correctly? Please help me, I do not want to waste $ 29.95 for anything.



  • I cannot promise you that these steps will work, but give it a try. Good luck.

    1. Unzip the IM0000. . . . -01_Michael4Base.zip file to a directory. 2) Navigate to that directory in Windows. 3) Open the Content folder; you should see three sub-folders: Readme's, Runtime, and .DS_Store. 4) Copy the Runtime sub-folder to the proper location in your Poser library.

    I hope these steps work for you. Please understand that they are just a suggestion.



  • I use Poser 11 Pro on Mac OS



  • @henrytred I know for V4 you need to run a setup script that is included with her. I can't remember if this is the same with M4.



  • @ghostship said in Michael 4 and POSER 11 Pro:

    @henrytred I know for V4 you need to run a setup script that is included with her. I can't remember if this is the same with M4.

    Yes it is, but I was never sure what it did other than put a weird icon on your desktop which I deleted, I hate software that impinges on my desktop!

    Tony probably has a video about it :)



  • @amethystpendant You and me both! ~wink~



  • I only understand that all this scam is used to steal money. And I'm not using what I paid.
    Sorry for my English, but I am Italian :-)



  • This is a paid product, so first of all you should contact the DAZ support! They are usually not that bad ;-)

    Other than that the steps outlined by @abrahamjones are the same on Mac.

    Cant remember if running a script was necessary for the M4 base. But i do remember that the script on Mac was buggy. It lacked an execution flag. Maybe they fixed that meanwhile.



  • You can also use the DAZ download manager. You can download this from DAZ and set the path to whatever runtime you want M4 in.
    This has the added advantage that if you use it to download V4 and morph packages it automatically. Or you can create a poser library "My DAZ 3D Library" in your public documents folder or equivalent on Mac and DAZ download manager will automatically install the content in this.


  • Poser Ambassadors

    Yes, the easiest method is to use the daz install manager and point it to your Poser 11 runtime.

    That "funny icon" on your desktop is the initialization script, which will need to be run each time you add new morph sets to use with M4. But if you use the daz install manager then you won't need to use that script.



  • @henrytred if you have only extracted the M4 files from their zip archives and copied them to the correct place in your Runtime folder (I use a separate Runtime for Michael 4, to keep things simple), you will then need to execute both of the bash shell scripts indicated below.
    0_1550025537861_Screen Shot 2019-02-13 at 1.38.34 pm.png
    Each of these scripts invokes the DzCreateExPFiles.app executable with different parameters to parse the Michael 4, and M4Genitalia folders respectively, to create the appropriate injection templates based on the contents of those folders.

    In other words, if you have installed additional add-on products to M4, like muscle morph packs, these scripts need to be run again to incorporate them into the loading process for the base M4 figure (and M4Gens). Once that's done, loading the figure from the Poser library will include all the necessary injection channels for the figure, so that the morph injection poses work correctly.

    You will also notice that there are some link shortcuts called "Update Michael 4 Base", etc. in the folder which contains the Runtime. These shortcuts/aliases invoke the DzCreateExPFiles-M4.command, so either way will work (alias or direct execution (double-click in Finder)).



  • @anomalausI unpacked all the zip folders: DxCreateExPFiles-M4.command ... it is not present in any folder.
    I have only DzCreateExPFiles-M4Gens.command :-(



  • @henrytred I was walked through the process with V4 here: https://direct.daz3d.com/forums/discussion/47761/victoria-4-2-morphs-and-elite-ethnic-morphs-aren-t-working-properly-on-a-mac-running-poser-10

    Dunno if that'll be helpful.

    The main thing I remember was that it was a nuisance, but it eventually worked.



  • @henrytred provided the new file retains execution privileges, you can just make a copy of the one you have and then edit the file in a text editor (it's just a bash shell script) and change the parameters. Here are the two files for comparison of what to change. I'd recommend duplicating the file you have and renaming and editing it, rather than saving the file I post, to retain execution privileges (NOTE: No carriage return after final "exit".

    DzCreateExPFiles-M4.command

    #!/bin/bash
    cd "$(dirname "$0")"
    ./DzCreateExPFiles.app/Contents/MacOS/DzCreateExPFiles "Michael 4" "M4"
    exit
    

    DzCreateExPFiles-M4Gens.command

    #!/bin/bash
    cd "$(dirname "$0")"
    ./DzCreateExPFiles.app/Contents/MacOS/DzCreateExPFiles "M4Genitalia" "M4Gen"
    exit
    


  • @anomalaus Finally everything is solved. Thanks to your help. Good luck friend. :-)