Rulers vs PS Paths?



  • I'm slowly in the process of migrating from PS7 to Clip Studio. One PS tool I made frequent use of was the Pen/Paths feature. I've gathered that the Ruler sub tools is Clip Studio's equivalent to PS Paths. But I'll admit they feel pretty unruly to me (pun partially intended.)

    With PS, I can lay my points down, edit/curve them as I wanted, and be done with it. I can lay a simple line to manipulate without having to "close the points as a complete shape." If that makes sense.

    I'm finding that I can't seem to do that with Clip Studio? Every time I use the rulers I find I ABSOLUTELY HAVE TO CLOSE A SHAPE OR ELSE I CAN'T SELECT ANOTHER TOOL AND SUDDENLY I'M LAYING POINTS CLEAR OFF THE CANVAS MILES AWAY FROM THE SIMPLE LINE I TRIED TO START WITH. It's giving me a strong case of whiplash, lol.

    I've tried messing around with the ruler's settings, but there doesn't seem to be a way to turn that issue off? Am I missing something, or are the ruler tools just built that way where you absolutely need to close your points into a complete shape?



  • The ruler pen just stops when you pull the pen away from the tablet. The Curve ruler can be tricky in the way you describe...you have to do a double click to stop the line and that can be tricky with a tablet pen.... but if you have the rocker switch on a Wacom pen set to double click ( on the back action of the rocker) then you just click the switch and its done...

    But in CSP I hardly ever use the rulers... In PS often the only way to get a really clean line was to draw a path and then stroke it but in CSP the line stabilization is so good that you just draw. And if you like to adjust the lines afterwards then draw on a vector layer and then you can drag the line wherever you want if its not in the right place



  • In the Tool Property Palette, the Curve Ruler has a Close Line option (you may have to open the Sub Tool Detail Palette to find it). That option may be checked forcing the curved ruler to close itself.

    But I'm with 888toto. There's not a lot of reasons to be using rulers like PS paths. Vectors are very easy to work with in CSP and easily edited. The only reason I can think of to use a ruler like a path is so you can draw the line with pressure sensitivity and not have to worry about the line shape - but CSP has the Redraw Line Width tool that can be used on a vector line, so....



  • Thanks for the info guys. I don't own a wacom, so it's just double clicking the usual way for me. Unfortunately it's very awkward, and in the end it still just forces the points into a completed shape--which I guess answers my question about it just being a simple curved line vs a closed shape.

    I liked using PS7 paths for a few reasons, it was more reliable to select some things than the magic lasso (which behaves exactly like CSP's curved ruler in that it gives me whiplash,) it was easier to make crisp cell shading than using a brush that didn't have the best stabilization, and I could make minor linework corrections using it. It also helped with creating crisp, accurate pattern pieces---because I do a bit of sewing too.

    I actually prefer to ink things traditionally, but circumstances are making me try to transition to a full digital method. I don't want perfect lineart in that each line has to be stabilized, so I opt to keep that brush setting low to help recreate the feel of an inked piece I normally would get traditionally. I need the paths/curved rulers in this case to help compensate in some areas.

    I'm actually finding it difficult to use the vector layers for inking, though I'm still too early on in learning the software to swear against it. Right now I'm finding it frustrating when I want to erase part of a line--it never behaves like I want it to. And I'm not really sold on editing lines in a vector fashion either.



  • Select the Curved Ruler tool and open the Sub Tool Detail Palette. Go to Continuous Curve and check to see if the Closed Line option is checked. If it is - uncheck it. If it isn't checked then I have no idea why your line is closing.

    0_1480462898605_closed.jpg

    There's very little difference to laying down a vector path using a mouse and laying down a ruler with a mouse. There is a continuous curve for both.

    0_1480463169201_direct draw.jpg

    You will find the continuous curve tool in the Direct Draw folder.

    0_1480463446432_control points.jpg

    Laying down control points is exactly the same for both a ruler and vector. With a vector path laid down, you can select the path using the Object tool. From the Object tool Tool Property Palette you can change the brush size, stroke color, the stroke itself (brush shape), and edit the control points.

    0_1480463654955_object.jpg

    Next go to the Correct Line tool category and find the Control Point tool.

    0_1480463750495_cp tool.jpg

    From here you can switch corners, change stroke density, thickness, and so on.



  • Editing the line with the Correct Line Width tool is as easy as selecting a control point and dragging left or right to thicken or thin.

    0_1480464669543_edit line.jpg

    The vector eraser has a few options.

    0_1480464697890_vector eraser.jpg

    You can erase part of a path to make two or more paths, You can erase a line up to another line, or you can erase a whole line.

    0_1480464811097_vector eraser 2.jpg

    In this example I used Erase up to Intersection and touched on the two ends of the two paths.



  • I've checked the ruler settings, and I've unchecked close line and it doesn't seem to solve my problem. I'll lay points down for the ruler, but CSP refuses to let me switch out to a different tool unless I close the ruler line into a complete shape. I've tried manually clicking different tools and end up with the whiplash I earlier described. I've tried to use keyboard shortcut keys, same problem.

    I don't know what I'm doing wrong.

    I'm not even sure what other information I could provide here. The software is so new to me and still so overwhelming that I'm not even sure what else to do to troubleshoot the issue.



  • Forget about selecting a tool while the ruler is active. You can't do it and it's pointless to try. You have to finish the line.

    If the Close Line option is unchecked then a double click of the mouse will end the line. If a double click does nothing to end the line then you have a problem. I'm curious if you are able to end the line on the Continuous Curve Spline tool in the Direct Draw category. If you can't then you'll have to contact Smith Micro support because the program isn't working properly.



  • There is one other way of ending the line without a double click. Try clicking Enter on your keyboard where you want the line to end.



  • Messing with the mouse and the enter key seem to finally be doing the trick. I've checked the continuous curve and that also works. Thanks so much for being patient with me, as well as the additional information on vector layers.