Folder Explorerer Not Showing All Folders when adding a new folder to the Library Poser 11



  • Yay, a new weird issue for me....

    When clicking the + sign to add a new folder to my Poser Library, the Browser window pops up like always. But instead of showing me all my folders in my "Content" folder, it only shows "Agatha" the last folder that I added to the Poser Library. I've deleted it, and tried again, but it just keeps showing only "Agatha." I've posted the Browser window and my File Explorer list of folders it SHOULD be showing.

    As you can see, I've bought a lot of stuff, and have never experienced this before. Is there a limit to the Poser Library number of folders one can have?

    Obviously, I can't import new material until this is resolved, and I'm trying to finish up a HUGE project. Any help is greatly appreciated!

    0_1555027794655_Poser Library Browser.png

    0_1555027914794_Actual Content of Poser Collections.png



  • @wesley I hope someone else can help you, because I've never used the Collections folder in all the years I've been playing in Poser.



  • @wesley Did you refresh your Poser 11 Content folder in the library? Try closing the folder. When the recycle symbol appears, click it and see what happens. Let us know.



  • Try your Collections folder recycle too. Looks like that where you keep Agatha.



  • As far as I'm aware the collections folder is where poser stores your favourites when you add something to your favourites from the library.
    I think all your folders are basically in the wrong place, you are getting the runtime poser uses for its internal purposes which is in the program files mixed up with the poser content runtimes which should be in a public documents folder.



  • Can you tell me what the folder names are in the ZIP you are trying to install? It should begin with RUNTIME

    RUNTIME folders are always installed beneath a top folder. The reason you aren't seeing your Agatha character installed in your library is because the library structure you are using isn't valid.

    It looks like you are trying to install it to
    Smith Micro > Poser 11 > Runtime > Libraries > Collections > Content > Agatha.

    Instead, providing there is a CR2 file in that Agatha folder, it should be installed in:
    Smith Micro > Poser 11 > Runtime > Libraries > Character > Agatha



  • @j-naylor73 said in Folder Explorerer Not Showing All Folders when adding a new folder to the Library Poser 11:

    As far as I'm aware the collections folder is where poser stores your favourites when you add something to your favourites from the library.

    Ahhh, I was wondering if that's what the Collections folder was for. I've never set up favorites, so that must be why I've not had any interaction with the Collections folder.



  • Thanks everyone for such prompt replies. I will try to address all the questions.

    1. eclark1849, I've refreshed it (upper right corner next to Poser 11 Content), but the problem isn't viewing what is in the Poser library. The problem is when I try to add something new to the library. The Poser Browser window will not display the folders in my Contents folder (except for Agatha) so I can't click unzipped folders to port them into Poser 11.
    2. With regard to my folder being in the wrong place, I have no doubt j.naylor7 and Deecey are correct. When really new to Poser, that was a logical spot to install new purchases, I thought. I never save favorites, and it has worked this (incorrect) way for 6 months now. Is it possible it has reached its limit and the Poser Browser won't recognize any folder anymore (besides Agatha?)
    3. Deecey, Agatha IS working correctly. I was just playing around with it when I was going to install to the Poser Library her dress and that's when I noticed Poser would ONLY show Agatha (see picture 1). You are right in that my entire collection is in "Smith Micro>Poser 11>Runtime>Libraries>Collections>Content>, and as I mentioned in #2 above, it seems as though all are in the wrong place. But Picture 2 shows all the folders that are in Collections folder, and the Poser Browser has always shown the contents of the Collections>Content just fine--until today.

  • Poser Ambassadors

    @wesley said in Folder Explorerer Not Showing All Folders when adding a new folder to the Library Poser 11:

    When clicking the + sign to add a new folder to my Poser Library, the Browser window pops up like always.

    Your description here took me quite a while to decipher, as well as your overall problem. Both have to do with an incorrect mental model in your head of what's going on here, and how you communicated your mental model. You actually deluded the others enough that they failed to help. I will try to straighten this out for you.

    I mean no disrespect, but we need to use words with care, and you have not done so, leading to some delay in getting to the bottom of this. As well, Smith Micro is continuing to give us inconsistent terms which leads to more grief. I will try to present some statements about these unhelpful UI elements so as to detach you from certain delusions.

    When clicking the + sign

    This is "the + sign". You did not click the + sign. This button says "Save to Library" in its hover tip.
    0_1555056188084_d42fcde3-a6bf-4b6f-97bc-dc7b46a33c05-image.png

    to add a new folder to my Poser Library

    This is the button that adds a new folder to your Poser library. You did not click this button either. This button says "Add a Folder" in its hover tip. You were not trying to add a new folder, which means to create from nothingness a folder that previously did not exist. You were trying to add an existing (not new) runtime folder to the list of runtimes displayed in your library window. This button doesn't do that, but it does have a + in it.
    0_1555056329891_0f0316a0-ff3d-4bc3-8ec6-f1bc608da865-image.png

    Here is the button you clicked, which also has a + in it but is actually a row of books.
    0_1555056362203_2fa92452-d93b-4e94-a54a-ddb79365594b-image.png
    This button says Add Library in its hover tip. This is what you clicked.

    We (the users) refer to "the library" often and we all mean this window that we use to view and manage our content, which is organized at top level in "runtime" folders. Smith Micro, the vendor, dissonently refers to a runtime here as a "Library" when they say "Add Library". How confusing.

    The library is the whole window, not the things you added into it. SM does us all some disservice here. The runtimes are special root folders that contain a specific set of childfolders, followed below by your content. You add runtimes to the library using the button you did push.

    Everybody with me so far?


  • Poser Ambassadors

    Your primary delusion is that you think your runtimes are inside the Poser 11 runtime. They're not. I mean - you sort of made them that way but it was wrong to do so and now everybody is having a hard time explaining what's going on.

    To locate what actual real folders exist in your runtimes as shown in the library, do this.

    0_1555057018339_e8f64f83-8377-4989-9672-82aec4345257-image.png

    Open the library display options as I've done at the bottom, and enable "Extended Details Panel". Forever after, you can now select something (a folder, a piece of content) and that panel will show you the details about it. The most important detail, the one you're struggling with, is "where is this?".

    As you should be able to discern from my other arrows, the Runtime parent folder name is what I see in the tree view (Baggins) and the particular subfolder within it is selected by the Props (hat) icon.

    The library combines your selected category of content (props, lights, materials) with your selected runtime or folder to assemble the actual path of the item it should be showing you. That path is revealed to you in the details panel.

    Using this panel you can literal "Show in Explorer" the folder in question, which will let you further explore what it contains using the Windows Explorer.


  • Poser Ambassadors

    0_1555057327459_36b39c9c-9ac8-457b-bc42-d5a1456a1e68-image.png

    Based on this screen shot you gave us, I can see where you keep your numerous runtimes. They are all in this one folder EXCEPT for Agatha, which you appear to have created two times. Only one of them is shown in your library, and you're confused about which one you added to the library.

    This folder, Poser 11, Runtime, Libraries, Collections, Content is a bad thing.

    You have placed all your runtimes inside the Poser 11 "internal" runtime which is special, and is also in a protected location (Program Files) within which you absolutely should NOT be adding content or mucking about AT ALL.

    Yes you got away with it, but for heaven's sake you're lucky you didn't lose an eye already.

    Anyway - if you select, in the library window, that BatGirl folder, I have no doubt that it will say it's in this place on your hard drive. As are all the other ones.

    Now you should understand that there is no REQUIREMENT that all your various runtimes are found in the same "content" folder as you've arranged. That was your choice. And it's fine to do that. I do that too.

    But I do NOT bury that inside the Poser 11 runtime - it's wrong to put a runtime inside a runtime and it will make certain things mysterious and confused.

    Second, it's doubly wrong to put your "external" runtimes inside the "internal" runtime. OMG


  • Poser Ambassadors

    So now you should be able to reset your mental model, confirm your beliefs with demonstrable evidence, and navigate around your hard drive to add new runtimes to your library.

    There is one more problem - the final nail in your coffin.

    You put data files, manually, in the "Program Files" folder. That is a protected folder and has weird and inscrutable behaviors you know nothing about. These behaviors were invented by Microsoft to put a wall up around your programs and defend you against malware that likes to peek and poke your program files and hack the hell out of you.

    Depending on which program you use and when you use it and who you're logged in as and whether or not you're running with elevated privileges, there are actually TWO different folders that answer to that path you think you're looking at.

    Collectively, these defensive behaviors and rules cause an infinite amount of confusion. They were meant to allow some legit older programs to access their data files in the nasty old way but they really just make it impossible to manage content on a Windows Computer, if that content is somewhere under Program Files.

    Don't do it. Seriously - you need to move those runtime folders out of Program Files and then rebuild your library window by adding them back after you moved them.

    I have not run into this in such a long time I can't remember the name of the hidden secret second folder where your stuff really is. I'll be back after a bit of googling.


  • Poser Ambassadors

    Found it. It's in a special folder with the name VirtualStore. Its location depends on your username. My username is ted_c. Here's where my VirtualStore is.

    0_1555058350487_1419a90f-876e-4105-a8ea-9e2a9ce4f9d7-image.png

    There are two "protected" folders in Windows, Program Files (which you trashed) and Program Files (x86).

    You can see inside there is a Program Files (x86) on my computer. Some 32-bit program(s) must have misbehaved, causing it to exist here for me. When I look inside, I see one of those programs was Git and the other was Hasbro Interactive/My Little Pony, which presence on my computer is puzzling to say the least.

    Look in your VirtualStore and see what you find. You may need to enable the display of hidden files and folders to get there as Windows really doesn't want you to know anything about reality here.


  • Poser Ambassadors

    One last bit of advice. There's a little-known tool called "Everything". It's a fantastic free utility that searches all your disks instantly for any file by any part of its name. It runs with elevated privilege so it can find stuff even if Windows is trying to hide it. When I say instantly, I mean before my finger finishes the last letter of the name. If you know something exists but you can't find it, use this tool to find it (or them if there are multiple) quickly.

    You can get it here:

    https://www.voidtools.com/

    0_1555059564793_87513d08-afe3-48c4-a394-ae578014bdb9-image.png


  • Poser Ambassadors

    "Everything" is so fast, I use it to run programs instead of the start menu or explorer or shortcuts. I just type excel.exe and there it is.


  • Poser Ambassadors

    @wesley said in Folder Explorerer Not Showing All Folders when adding a new folder to the Library Poser 11:

    the Poser Browser has always shown the contents of the Collections>Content just fine--until today.

    Regarding this particular statement, I suspect that what changed is you (probably unknowingly) enabled the dreaded User Account Control (UAC). Perhaps you had it turned off before, or it was malfunctioning and now it's working. Did you take a Windows update? Did you do any system restore, system repair, anything like that? Did you run any new antimalware software that perhaps strengthened your security? Or maybe you were running Poser as admin at different times, which would alter what it sees. Who knows.

    Bottom line - find those runtimes and put them in a proper place. Stay out of Program Files forever. Leave that to installers. Don't explore Program Files for any reason except to LOOK and really why should you need to do that?



  • Thanks all for the help! And a special thank you to bagginsbill for such a thorough and informative series of replies. Files have been moved from "No No" land, and safety stowed in my Documents. Everything is working like a charm now.


  • Poser Ambassadors

    @bagginsbill
    My compliments on explaining this issue to wesley.
    Well done!


  • Poser Ambassadors

    Awesome!