Transparency doesn't work with cloudy volume scatter?



  • Hello
    It's in so many cases an irritation that transparency doesn't work with cloudy volume scatter when I want to make atmosphere effects.

    Here an example. The eyes get black because of the Eyelashes they use transparency. In the picture below you see the first example ist rendered with a cube for atmosphere. The density has a cloud effect. There is a tranparency issue with the eyeleshes, the eyes get black.
    In the second example there is the same without a cloudy density for the volume scatter. Tranparency of the eyeleshes works as it should.

    0_1558243875279_cloudy scatter.jpg

    Here are the render settings. I use 32 transparency jumps!
    0_1558244136878_render settings.jpg

    Atmospehric effects are very important for me, but they don't work in poser if you use cloudy density. That's a always an irritation. I often have transparency. I need it in the leaves of trees. I many plants, in cloth and in the eyelashes of the figures. Often I can correct it with afterworks, but not always

    Will Poser solve this bug? Or has anybody a solution for this issue. I tried so many things, but I did not find any solution.



  • Where are you applying this material? To the cube? Why not use the Poser Atmosphere tab?
    0_1558271497817_atmosphere.png



  • It's in the materials room, just click the draw down menu on the advanced tab and you will see it.



  • correct me if I'm wrong. Aren't scatter effects "transmission" and not "transparency?"



  • @joker a couple of observations: 1) scatter volume needs Poser lights to show up the best, just using a skydome makes the effect hard to see. 2) I got a strange color shift when using a colored scatter like you did in your setup. I used a light blue color for the scatter and when the scatter effect passed in front of Andy the fog shifted to red. The math guys here will be able to tell you why that is but I have no clue. 3) I got it to work with a simpler setup. Keep in mind that my camera is OUTSIDE of the scatter cube.
    0_1558275441916_scatter image.jpg



  • @ghostship Thank you for your answer, but you missanderstood my issue

    The problem is , when you use a object with transpercy inside the cloudy scattered cube.

    0_1558296244908_1515077417813-temp.jpg

    On this pic you see another example. Here I have transparent parts of cloth inside a cloudy scattered cube.

    summarized: Objects with transparent parts in the material don't work in a cloudy scattered cube. It also does not work when I use the "Atmospehere" in the material room (only cloudy atmosphere does not work). There is the same issue.

    To test. Set a plane into the cloudy scattered cube at set the material to transparency = 1
    Render it with superfly. you will see. the transparency does not work correctly.



  • @rokketman Thank you. but also when I use the "Atmosphere" I have the same issue.



  • This is a plane with transparency = 1 in a cloudy scattered cube
    0_1558298444022_plane.PNG


    This is the same transparency plane in not cloudy scattered cube. This is correct, you can't see the transparent plane0_1558298540900_plane2.PNG



  • @joker In the cloudy scattered cube, (the same is in "Atmospehere"). you see the 100% transparent plane. That's the bug I mean.

    Transparency does not work in cloudy scatterd cube oder Atmospehere.



  • @joker what root are you using for the transparent parts?



  • @joker the other thing I notice is that you have your clouds texture plugged into both of the multiply inputs. Shouldn't it be just the top number that is plugged in?



  • @joker I'm not getting the same problem you are. Hair is transparent and so are eyelashes and corneas. Not having any problems with these in a render. must be a render setting you are using or your mat setup for either the fog or the transparent item. Right now I'm guessing the fog setup is borked due to the double plugged in cloud texture.



  • @ghostship i assume you don’t use branched path tracing, right?
    @joker does the problem disappear with branched path tracing off? Just a guess…



  • @nagra_00_ no BPT here unless I want a crash.



  • @ghostship I just ran a sim without any of those issues too. I used the primitive box as the atmosphere. No problems at all, until I started messing with the math modes with cycles. I don't know enough about cycles to know how the math modes respond, so I just tried to use them as I would on the atmosphere tab. No bueno.





  • Thank you for your answers, but all your proposals have no effect. It doesn't matter wich base node I use or if I use math nodes or not, or if path brachned is on or off.

    But the effect is not strong in every case. The effect is stronger if you use a big scaled clouds. scale = 100 for example.

    A year a go we discuss this case and we found no solution.
    https://forum.smithmicro.com/topic/2818/transparent-issue-with-scattered-volume-fog

    it depends on some factors that get this effect. It depends on lights also how strong the effect is.

    I can not uplaod any files here. so I can't share it to show you my example





  • @joker a potential problem with props containing a volumetric shader, is that scaling the prop requires inversely scaling the density, since the density is in geometry units, not worldspace units.

    Here's my comment from a Volumetric Shader thread on this forum:

    Absence of scaling is an important requirement for the density settings of volumetric absorption and scattering in SuperFly. My experiments with standard props scaled up to large volumes to enclose the camera and scene objects has required equivalent (and logically appropriate) scaling down of density settings (to maintain their mesh-relative units). I suspect there may be some fixed precision operations involving density, which are intended to speed up the calculation of volumetric effects during renders, beyond what can be achieved by using floating point operations. The side-effect of using fixed precision is that tiny density scales can underflow to zero, thus reducing the possible effects to either on, but too much (totally opaque) or off, as I have observed in such experiments.

    Without object scaling, changes to volumetric effects are easily seen with small value changes to the density inputs from their default of 1. If one needs to scale a volumetric prop to match a scene, the simplest way to revert to unitary scales is to open the grouping tool, select all the facets of the scaled prop (or actor) and spawn a new prop, then delete the original, scaled prop.

    I think you may also need to bump up your Transmission Bounces, perhaps.



  • @anomalaus Thank you for your answer, but I don't understand what and how it's to change.

    But maby anybody can change this example file in this way, that the transparent plane is not visible anymore in this cloudy fog cube?

    https://drive.google.com/file/d/153BihsTj2H02ZZlYyzeoMlvCnC-s8tN4/view?usp=sharing

    0_1558335967479_plane2.PNG