Basics for adding UV maps and textures to model



  • Misfit Model 3D is an OpenGL-based 3D model editor that works with triangle-based models.
    That might be part of the problem. I will give you a link to the two modelers I mentioned. Wings is also open source and fairly easy to learn. Blender is about to release a newer version, but it's got a steep learning curve. Wings also has a fairly nice UV mapping tool set.
    http://www.wings3d.com/
    https://www.blender.org/
    I am not saying that modeling in tri's is all bad. But the contention is that for rigging and animating, you want to use quads. I am also thinking your tri's based modeler isn't reading the probable quad based model correctly.



  • Attached is the model's rendered head with the head and eye map textures applied and the 2D head map. Let me know if you want to see the 2d eye map

    0_1558554515854_HeadRender.JPG 0_1558554538401_HeadMap.JPG



  • @shepdaddy Yeah, the head isn't mapped to that texture. Here is another free utility that will show you what your texture map looks like. It's fairly basic and there is a pro version, but this one will let you see what you're dealing with. I think, from what I am seeing, the model is all tri's.
    Can you post a wire frame of that model so I can see it?



  • Oops, I forgot the link:
    http://www.uvmapper.com/



  • Looks like tri's to me, but then I'm not the subject matter expert. Here are a couple screenshots of the wire frame. I have both versions of UVMapper installed on my system. Just haven't had a need to use either one, until now.

    0_1558556219754_Headshot2.JPG

    0_1558556236240_Headshot1.JPG



  • BTW, I forgot to attach a UVMap of the head I got with this model in a JPG file...this is what it looks like. As I mentioned earlier, I think I have all the pieces to this puzzle, I just need to figure out how to put it together.

    0_1558556586105_HeadUVMap.JPG



  • @shepdaddy The UV map is really hard to see.



  • @rokketman Ok, downloaded it and took a look. The head does indeed look like it was modeled in tri's, and your map is quads. It's either not for that model, or something went wrong with it somewhere between you downloading it and up to this point. I suspect it was taking the model into Misfit that did it. Since it's a tri modeler, it probably converted the mesh into tri's and that messed up your UV mapping.



  • Sorry bout that....hopefully this one is easier to see.

    0_1558557466419_HeadUVMap.JPG



  • @shepdaddy Yeah, I got a look at it using GIMP to add a gray scale. As I said, this is a mostly quad mesh, and your figure is all tri's. I suspect it got converted in Misfit and that's why you can't get the UV's to work now.



  • Well, thank you very much for all of your help, and I can confirm you're absolutely correct. I opened in Poser the original OBJ that was downloaded and changed to wireframe and its all quad's. So Misfit Model is indeed converting the quads to tri's and changing the mesh.

    I need to look to using a different 3D modeler, like Wings 3D. I have Blender installed already and started to use it but it does indeed have a very steep learning curve and I really don't need such a powerful tool to do simple vertex grouping.

    Think Wings 3D will solve a lot of my problems. Thank you for that recommendation too.

    Cheers!



  • @shepdaddy Any time. One thing I have noticed about the Poser community over the last 10 years that I have been a part of it, they are open and friendly and willing to help. I learned everything I know from the great folks here and other Poser forums.