Shadow artefact when main camera moves



  • Hi,

    I use Poser 11 Pro on an iMac from 2011 with macOS High Sierra.

    I´ve got this problem: When I render a scene with a static camera everything is fine, but when I move the camera just a little bit, I get those artefacts, which are not very nice. I already turned off ambient occlusion for all lights in the scene and made the ground prob invisible. It seems to be just the carpet that makes those problems. I turned off the light ermitter as well, but that had no effect. In an earlier rendering I used 640x480px instead of 1280x720 and didn´t have this issues.

    Here is a 1 sec. clip to show you what I mean:

    And here are my render settings in firefly mode:
    0_1560127665801_Bildschirmfoto 2019-06-10 um 02.08.28.png

    Does someone know this problem and can tell me how to fix it?

    Thanks in advance!



  • @steve_vaii I had a funny odd problem with dark render artefacts that looked like shadows. I fixed it by subdividing the surface that they were on. In my case it was a terrain that i had scaled up quite a lot. Hope this helps.



  • As Esther said, try adding subdivision to the carpet. It could also be that there are reversed normals in the model. You'd need a 3D model app to fix that.



  • @rokketman And if you don't want or need the shadows, just uncheck Cast Shadows in the box.



  • I doubt this has anything to do with the shadow issue, but thought I'd mention it anyway.

    Your render settings show "Use Displacement maps" checked on the right side of the Render Settings dialog, but the "Displacement Bounds" setting is set to .000. So basically, the displacement maps won't work. That displacement bounds value should be set at least the same value as the displacement map settings in the materials. Or, start at .005 and see if that works.



  • Im confused, you post firefly render settings, but the very short clip you posted looks to me like a quick low quality preview render...



  • Thanks to all of you! These are alot of useful things I didn´t know before. I´ll let you know, which method worked at the end :)
    @JAFO The clip is rendered with those firefly settings. The bad quality is because of YouTube´s compression.



  • Allow me to make one more suggestion

    It looks to me like you need to adjust some of your render settings. Here's the easiest way to do that:

    From the FireFly render settings tab, at the top of the Quality section you'll see two radio buttons. Auto Settings, and Manual Settings.

    Click the Auto Settings button, and adjust the slider AT LEAST somewhere in the middle (the lower the setting, the lower the quality, but the faster the render will take. Higher settings will take longer to render but will be much better quality. You'll have to play with the automatic quality slider until you get a balance of speed vs quality that is acceptible to you.

    So in this example I've set it to two notches past the center, like so:

    0_1560378221582_auto settings.png

    Now, go back up to the top, and click the Manual Settings button. Initially you won't see anything change. But click the Aquire from Auto button at the top, and you will see the values change. I also changed the displacement bounds settings (you won't need displacement unless your materials make use of them)

    0_1560378380923_manual settings.png

    Hope this helps.