How can I disable Gamma correction in Superfly?



  • Both scene fixer and ezskin3 are available here http://snarlygribbly.org/snarlyspace/index.html make sure you get ezskin3 older versions don't with for superfly textures. Also use scene fixer with caution. It wasn't written for poser 11 and has some problems with some of the changes made to the matroom. Save before using it.



  • Thank you. What settings should I pick?
    0_1481086242802_What settings to pick.jpg



  • 0_1481086580571_what-settings-to-pick.jpg



  • I'm still not happy. I don't get it. Something is wrong. What is it?

    Without gamma and without using scene fixer:
    0_1481174762612_NoGammaNoCorrection.png.jpg

    With gamma and with using scene fixer:
    0_1481174796864_Gamma+Correction.jpg

    The last image just looks so bad overall. No contrast, no saturation and green-grey skin...



  • @amanda what does the material look like for the face now in the mat room for the second "bad" looking image?



  • Without gamma and without using scene fixer:
    0_1481248793429_MAT no correction.jpg

    With gamma and with using scene fixer:
    0_1481248822782_MAT correction.jpg

    Without gamma and with using scene fixer:
    0_1481249051711_MAT no gamma correction but with using scene fixer.jpg



  • @amanda Time to simplify. remove the stuff plugged into the alternate diffuse and alternate specular. turn diffuse to 1 and plug in the two maps as I have shown in my image. throw out/delete the other bits of rubbish in that shader that you unplug.

    0_1481251303270_mat-correction.jpg


  • Poser Ambassadors

    This material you're dealing with is loaded with tricks that were added because we didn't have gamma correction and we didn't have scatter.

    Both tricks involve the judicious and careful addition of extra light with carefully modulated colors. The tricks were designed specifically for an inaccurate, non-physical, non-linear rendering equation, which is all we had back then. Some of the pieces of this shader were designed and published by me and widely copied IN 2006 and after. The tricks were compensation for basically a broken renderer.

    You should not be trying to use this shader today. You're now trying to use it with a correct renderer and it won't look right.

    Imagine you learned to drive a broken car, that always turned less than you told it to. So you learned to get that car to go where you wanted by oversteering.

    Then you get in a modern, new, correctly working car, and your oversteering sends you immediately off the road. That's what you're experiencing here.

    In this case, you want a modern skin shader that goes with this modern renderer. I have designed newer shaders for this purpose and they're at your fingertips by running EZSkin.


  • Poser Ambassadors

    @ghostship said in How can I disable Gamma correction in Superfly?:

    @amanda Time to simplify. remove the stuff plugged into the alternate diffuse and alternate specular. turn diffuse to 1 and plug in the two maps as I have shown in my image. throw out/delete the other bits of rubbish in that shader that you unplug.

    0_1481251303270_mat-correction.jpg

    It's not fair to call it rubbish. It was actually damn clever and useful TEN YEARS AGO.



  • @bagginsbill lol did not mean to alienate anyone. Did not know if it was one of your shader things or one from a vendor that had gone astray.


  • Poser Ambassadors

    It's not exactly mine - the vendor has gone a bit astray.

    The blue tint and then red ColorRamp modulated by a Diffuse node output was, at the time, a very useful invention for faking human subsurface scattering. However, the exact shades of dark red don't translate to a gamma correcting renderer, and the shades I used were much more red than here, which is in the yellow hue area. Which is kind of odd since this shader actually uses a scatter node with the blue tint, thus removing the proper scatter color and needing it to be added back. It is a bit wonky.


  • Poser Ambassadors

    Note that trying to use a Diffuse (lighting) node as modulator for the ColorRamp is totally illegal in Cycles/SuperFly and that whole section gets ignored by SuperFly.



  • Is this correct?
    0_1481253330683_Is this correct.jpg

    This is what I get now. The face skin looks too bright and pink.
    0_1481253350145_This is what I get now.jpg

    It was better before:
    0_1481253379259_Face skin still was better before.jpg

    This is what I get after disabling HSV Exponential:
    0_1481253721839_After disabling HSV Exponential in render settings.jpg



  • I just tried EZSkin3.
    It says: "This figure is not supported."



  • @amanda my other thought is that the lights are overpowering everything.

    try one of my light sets and see if that helps. Also you should use the ezskin3 script like @bagginsbill suggested.

    http://www.sharecg.com/v/86639/browse/11/Poser/Studio-Portrait-Lights-for-Poser-11-Poser-11-Pro



  • EzSkin3 gives me an error: "This figure is not supported."
    0_1481256570525_Not Supported.jpg



  • ezskin you can make a custom profile that will work for your figure. Click edit and select a shader type for the material zones. they are pretty self explanitory on what goes where.



  • @amanda I have Genesis 2 in my runtime and ran it through EZSkin3 with @bopperthijs Superfly plugin and got good results to confirm that this works.



  • @amanda here are my render settings for Firefly and the test render of Genesis 2 male with default light set and ezskin shaders.

    0_1481258364426_render settings.jpg
    0_1481258378734_Gen2 test.jpg



  • Genesis can use the Daz gen 4 figures figure definition. Click on editor then under use figure definition, choose DAZ Gen 4 and click add figure. The list of shaders should update. If you use Genesis a lot, you can save it to that definition by clicking update definition towards the bottom.